[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#430054: marked as done (gnome-apt: FTBFS with g++-4.2: 'gettext' was not declared in this scope)

Your message dated Tue, 11 Sep 2007 09:02:06 +0000
with message-id <E1IV1dG-00043c-Rt@ries.debian.org>
and subject line Bug#430054: fixed in gnome-apt 0.4.9-3
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: gnome-apt
Version: 0.4.9-2
Severity: important

From my pbuilder build log, using a chroot with packages mostly from sid,
except that gcc-defaults is from experimental:

Making all in gdeb
make[4]: Entering directory `/tmp/buildd/gnome-apt-0.4.9/src/gdeb'
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12   -I/usr/include/libgksu1.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libgksuui1.0 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12   -DPREFIX=\"/usr\" -DSYSCONFDIR=\"/etc\" -DDATADIR=\"/usr/share\" -DLIBDIR=\"/usr/lib\" -DGNOME_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGLIB_DISABLE_DEPRECATED -DG_LOG_DOMAIN="\"GDeb\"" -DGNOMELOCALEDIR=\""/usr/share/locale"\"    -g -O2 -DG_DISABLE_CHECKS=1 -MT main.o -MD -MP -MF ".deps/main.Tpo" \
          -c -o main.o `test -f 'main.cc' || echo './'`main.cc; \
        then mv -f ".deps/main.Tpo" ".deps/main.Po"; \
        else rm -f ".deps/main.Tpo"; exit 1; \
main.cc: In member function 'virtual std::string DebPackage::Status()':
main.cc:73: error: 'gettext' was not declared in this scope
main.cc: In constructor 'DebPackage::DebPackage(const std::string&)':
main.cc:115: error: 'gettext' was not declared in this scope
main.cc:122: error: 'gettext' was not declared in this scope
main.cc:128: error: 'gettext' was not declared in this scope
make[4]: *** [main.o] Error 1
make[4]: Leaving directory `/tmp/buildd/gnome-apt-0.4.9/src/gdeb'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/buildd/gnome-apt-0.4.9/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/buildd/gnome-apt-0.4.9'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/gnome-apt-0.4.9'
make: *** [build-stamp] Error 2
Daniel Schepler

--- End Message ---
--- Begin Message ---
Source: gnome-apt
Source-Version: 0.4.9-3

We believe that the bug you reported is fixed in the latest version of
gnome-apt, which is due to be installed in the Debian FTP archive:

  to pool/main/g/gnome-apt/gdeb_0.4.9-3_amd64.deb
  to pool/main/g/gnome-apt/gnome-apt_0.4.9-3.dsc
  to pool/main/g/gnome-apt/gnome-apt_0.4.9-3.tar.gz
  to pool/main/g/gnome-apt/gnome-apt_0.4.9-3_amd64.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 430054@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Michael Ablassmeier <abi@debian.org> (supplier of updated gnome-apt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue, 11 Sep 2007 10:11:16 +0200
Source: gnome-apt
Binary: gdeb gnome-apt
Architecture: source amd64
Version: 0.4.9-3
Distribution: unstable
Urgency: low
Maintainer: abi@grinser.de
Changed-By: Michael Ablassmeier <abi@debian.org>
 gdeb       - graphical package inspection tool
 gnome-apt  - graphical package manager
Closes: 417206 430054
 gnome-apt (0.4.9-3) unstable; urgency=low
   * QA upload.
   * Fix FTBFS due to missing #include (Closes: #430054)
   * Add Patch for gcc-4.3 compatibility (Closes: #417206)
   * Adjust clean target in debian/rules
   * Use debian/compat rather than exporting it in debian/rules
   * Adjust menu file, replace obsoleted Section.
 b063c25ce055a9426aca2c2dcd02e9b2 597 gnome optional gnome-apt_0.4.9-3.dsc
 6cbce82280e2cb4686b976c18602a60d 584421 gnome optional gnome-apt_0.4.9-3.tar.gz
 717077298b0c1724b7d794f4e8a33d37 251580 gnome optional gnome-apt_0.4.9-3_amd64.deb
 4b84d3928324ff10a50e997c1f844bad 30992 utils optional gdeb_0.4.9-3_amd64.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: