[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#440414: libgnome-dev switched to db-4.6 but libgnomemm-dev and libglade-gnome0-dev are still refering to `/usr/lib/libdb-4.5.la' in the la file.

Package: libglade-gnome0-dev
Version: 1:0.17-8+b1
Severity: serious

I have just tried to rebuild gabber on current sid, it failed with:

/bin/bash ../libtool --tag=CXX --mode=link g++  -g -Wall -O2 -s   -o gabber  main.o eggtrayicon.o gtk2-funcs.o gtkplugxembed.o gtkspell.o gtkurl.o xtext.o AddContactDruid.o AgentInterface.o AutoAway.o BaseGabberWindow.o ChatView.o ConfigManager.o ContactInfoInterface.o ContactInterface.o DebugInterface.o ErrorManager.o EventManager.o FilterInterface.o FTInterface.o GabberApp.o GabberGPG.o GabberLogger.o GabberUtility.o GabberWidgets.o GabberWin.o GCInterface.o GPGInterface.o GroupsInterface.o IgnoreInterface.o MessageManager.o MessageViews.o PrefsInterface.o RosterInterface.o RosterView.o S10nInterface.o StatusInterface.o TCPTransmitter.o WelcomeDruid.o GnuTLSAdapter.o SSLAdapter.o -rdynamic -L/usr/lib -lglade-gnome -lglade -lxml -lz -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgnome -lgnomesupport -lesd -laudiofile -ldb-4 -lgnomemm -lgtkmm -lgdkmm -lgtk -lgdk -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -lsigc -lpthread  -lgnutls -lgnutls-extra ../jabberoo/src/libjabberoo.a ../jabberoo/libjudo/src/libjudo.la -lxml
libtool: link: cannot find the library `/usr/lib/libdb-4.5.la' or unhandled argument `/usr/lib/libdb-4.5.la'
make[3]: *** [gabber] Error 1

ametzler@argenau:/sid/home/ametzler/GABBER/gabber-0.8.8$ grep -l /usr/lib/libdb-
4.5.la /sid/usr/lib/*la

Both libglade-gnome0-dev and libgnomemm-dev need to make the
version requirement for libgnome-dev in both build-depends and depends
more strict. - libgnome-dev (>=1.4.2-37)

cu andreas
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'

Reply to: