[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#393419: marked as done (Source package contains non-free IETF RFC/I-D's)

Your message dated Thu, 23 Aug 2007 19:17:04 +0000
with message-id <E1IOIAy-0006OE-Cd@ries.debian.org>
and subject line Bug#393419: fixed in vpim 0.360.dfsg1-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: vpim
Version: 0.15-1
Severity: serious


This bug has been filed on multiple packages, and general discussions
are kindly requested to take place on debian-legal or debian-devel in
the thread with Subject: "Non-free IETF RFC/I-Ds in source packages".

It seems this source package contains the following files from the
IETF under non-free license terms:


The license on RFC/I-Ds is not DFSG-free, see:
 * http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=199810
 * http://release.debian.org/removing-non-free-documentation
 * http://wiki.debian.org/NonFreeIETFDocuments

The etch release policy says binary and source packages must each be free:
 * http://release.debian.org/etch_rc_policy.txt

The severity is serious, because this violates the Debian policy:
 * http://www.debian.org/doc/debian-policy/ch-archive.html#s-dfsg

There are (at least) three ways to fix this problem.  In order of

1. Ask the author of the RFC to re-license the RFC under a free
   license.  A template for this e-mail request can be found at

2. Remove the non-free material from the source, e.g., by re-packaging
   the upstream archive and adding a 'dfsg' version name to it.

3. Move the package to non-free.

I went over many packages looking for names of likely non-free files,
and there may be false positives.  If this is the case for your
package, I'm sorry for the noise.  I'll modify the scripts to take
into account false positives when I learn of them, and publish the
list of exceptions under "Known exceptions" at


--- End Message ---
--- Begin Message ---
Source: vpim
Source-Version: 0.360.dfsg1-1

We believe that the bug you reported is fixed in the latest version of
vpim, which is due to be installed in the Debian FTP archive:

  to pool/main/v/vpim/libvpim-ruby1.8_0.360.dfsg1-1_all.deb
  to pool/main/v/vpim/vpim_0.360.dfsg1-1.diff.gz
  to pool/main/v/vpim/vpim_0.360.dfsg1-1.dsc
  to pool/main/v/vpim/vpim_0.360.dfsg1.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 393419@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matej Vela <vela@debian.org> (supplier of updated vpim package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu, 23 Aug 2007 21:12:51 +0200
Source: vpim
Binary: libvpim-ruby1.8
Architecture: source all
Version: 0.360.dfsg1-1
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
 libvpim-ruby1.8 - vCard and iCalendar library for Ruby
Closes: 393419
 vpim (0.360.dfsg1-1) unstable; urgency=low
   * QA upload.
   * Really remove non-free RFCs (sorry!).  Closes: #393419.
 71572ca6964d6b89ebf3d4525bb1e6e8 586 interpreters optional vpim_0.360.dfsg1-1.dsc
 8ca4654ec1082789c3be12ac4f792ad4 92186 interpreters optional vpim_0.360.dfsg1.orig.tar.gz
 471e9ba2a7a5de7e89d9c688ccca5af2 3055 interpreters optional vpim_0.360.dfsg1-1.diff.gz
 c0cb04fc7b5b91d50dc91435280fd001 85742 interpreters optional libvpim-ruby1.8_0.360.dfsg1-1_all.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: