[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#436740: fpm: Missing menu file, one provided.

Package: fpm
Version: 0.60-2
Severity: wishlist

I like to copy/paste, how about you?

cat > usr/share/menu/fpm << EOF
	       longtitle="Figaro's Password Manager"\

I'm more interested in the completeness of this, then acctualy getting
the menufile into fpm.  If I'm a package maintainer what else would I
need to type?  Would I need to add this to a project?  Some how this
file get's included in the diff during the source upload, I think it
belongs in the debian folder.  Hmm there seams to be some hols in the
documentation regarding this.  I don't have time right now to look at
how other pkgs are doing this.

What I'd like to know is what would normaly be typed to have a file
get inserted into the installing systems file system?  This file need
not be a confile since there are overides at system(/etc/menu) and
user level.

-- System Information:
Debian Release: lenny/sid
  APT prefers stable
  APT policy: (700, 'stable'), (650, 'testing')
Architecture: ppc64

Kernel: Linux 2.6.18-4-ppc64 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages fpm depends on:
ii  gdk-imlib11    1.9.14-32                 imaging library for use with gtk
ii  libart2        1.4.2-35                  The GNOME canvas widget - runtime 
ii  libaudiofile0  0.2.6-6                   Open-source version of SGI's audio
ii  libc6          2.5-0exp3                 GNU C Library: Shared libraries
ii  libdb3         3.2.9+dfsg- Berkeley v3 Database Libraries [ru
ii  libesd0        0.2.36-3                  Enlightened Sound Daemon - Shared 
ii  libglib1.2     1.2.10-17                 The GLib library of C routines
ii  libgnome32     1.4.2-35                  The GNOME libraries
ii  libgnomesuppor 1.4.2-35                  The GNOME libraries (Support libra
ii  libgnomeui32   1.4.2-35                  The GNOME libraries (User Interfac
ii  libgtk1.2      1.2.10-18                 The GIMP Toolkit set of widgets fo
ii  libice6        1:1.0.3-2                 X11 Inter-Client Exchange library
ii  libsm6         2:1.0.3-1                 X11 Session Management library
ii  libx11-6       2:1.0.3-7                 X11 client-side library
ii  libxext6       1:1.0.3-2                 X11 miscellaneous extension librar
ii  libxi6         1:1.0.1-4                 X11 Input extension library
ii  libxml2        2.6.28.dfsg-1             GNOME XML library

fpm recommends no packages.

-- no debconf information

Reply to: