[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#392397: xracer bug #392397



On Wed, 27 Jun 2007 00:11:03 +0800
"Ying-Chun Liu (PaulLiu)" <grandpaul@gmail.com> wrote:

> > I'll look at the package fixes you have in debian.mentors on Thursday
> > and if it checks out, I'll sponsor.
> > 
> However, I'm using the epoch, so the new package is at new location:
> http://mentors.debian.net/debian/pool/main/x/xracer/xracer_0.96.9-1.dsc
> 

OK, there is one glitch. I happen to have an old version of autoconf
installed (due to building old QA packages) and xracer broke with this
version:

FATAL ERROR: Autoconf version 2.52 or higher is required for this script
make: *** [configure-stamp] Error 1

debuild: fatal error at line 1228:
dpkg-buildpackage -rfakeroot -D -us -uc failed

$ dpkg -l "autoconf*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                      Version                   Description
===================================================================================================================
ii  autoconf                  2.61-4                    automatic configure script builder 
un  autoconf-archive          <none>                    (no description available) 
un  autoconf-doc              <none>                    (no description available) 
ii  autoconf2.13              2.13-58                   automatic configure script builder (obsolete version)

Therefore, you should add a versioned dependency on autoconf and a Conflicts: 

debian/control:
Build-Depends: ..., autoconf (>= 2.52), ...
Conflicts: autoconf2.13
(The Conflicts is important because autoconf2.13 is a suggested
dependency of one of the xracer dependencies - check the pbuilder log -
and because autoconf2.13 can be installed alongside autoconf >= 2.52,
as on my system.)

Suggested packages:
  autoconf2.13 autobook autoconf-archive gnu-standards autoconf-doc
  automake1.10-doc dh-make psgml docbook-xml docbook-dsssl cvs gettext-doc
  libglide3 libtool-doc g77 fortran77-compiler gcj procmail graphviz
  sgml-base-doc perlsgml doc-html-w3 opensp libxml2-utils doc-base
Recommended packages:
  automaken libltdl3-dev gs gs-aladdin libmail-sendmail-perl
  libcompress-zlib-perl
The following NEW packages will be installed:
  autoconf automake autotools-dev bzip2 debhelper diffstat docbook

This isn't really your fault, it is one of those things that would only
appear on systems that have been used to build older packages. However,
it could easily result in someone opening a FTBFS bug on the basis that
although it builds nicely in pbuilder, it has a 'hidden' problem
building on a full system. (i.e. most people checking for fail-to-build
bugs will have things like autoconf2.13 lying around as a result of
some of those tests.) The package should declare the conflict to dpkg
rather than failing during the build itself.

The only other thing is that quilt adds support for two translations,
there could easily be more. The po-debconf package is not just for
debconf translations, there are people on the debian i18n list who can
help you provide translations for packages too. What translators need
is the xracer-0.96.9/po/xracer.pot file and you can probably unpack the
source tarball and point podebconf-report-po at the (patched) po/
directory. Run once on it's own (checks that the existing patches are
up to date - you can skip that email if they are) and run again with the
--call option to ask for new translations. Then, once the translations
are in, create (yet more) quilt patches to package them.

Now translators like to handle this by:
1. having the chance to translate prior to a 'major' upload (e.g. new
release, change of maintainer, etc.)
2. can choose to send new translations to you direct or as wishlist
bugs against the package which you can then close in the changelog
3. need a deadline of some sort, calculated with some regard to the
amount of translating that needs to be done. For a small translation
like xracer, you could easily ask for 10days, possibly 7.

The epoch is working nicely:
$ apt-cache policy xracer
xracer:
  Installed: 1:0.96.9-1
  Candidate: 1:0.96.9-1
  Version table:
 *** 1:0.96.9-1 0
        100 /var/lib/dpkg/status
     0.96.9-13 0
        500 ftp://ftp.uk.debian.org unstable/main Packages

That means that your epoch version is clearly seen as the upgrade from
the current version in the archive which is correct. Without the epoch,
0.96.9-13 would replace 0.96.9-1.

I don't have a joystick to fully test the package but it installs OK
and appears to run (with a message about the lack of a joystick) even
though I can't really race.

I'll be happy to sponsor this once the autoconf issue is resolved and
if you decide to call for some new translations, I'll upload it for you
once those are in.

-- 


Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpxbz9mBrcOx.pgp
Description: PGP signature


Reply to: