[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#382202: marked as done (adonthell: don't include your copy of sdl_ttf and build-dep on libsdl-ttf2.0-dev instead)

Your message dated Tue, 19 Jun 2007 19:11:20 +0200
with message-id <87ir9jg98n.fsf@slavuj.carpriv.carnet.hr>
and subject line Fixed in NMU of adonthell 0.3.4.cvs.20050813-2.2
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: adonthell
Severity: important

adonthell's package contains an old SDL_ttf source while it could just
build-depend on an existing Debian package (libsdl-ttf2.0-dev).

This makes bugs and security fixing harder because bugs in SDL_ttf will
also happen in adonthell.

So please consider build depending on libsdl-ttf2.0-dev.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-1-686
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)

--- End Message ---
--- Begin Message ---
Source: adonthell
Source-Version: 0.3.4.cvs.20050813-2.2

Now that adonthell is orphaned, bugs fixed in non-maintainer uploads
can be closed.  The original .changes file follows.

Hash: SHA1

Format: 1.7
Date: Thu, 10 Aug 2006 20:47:56 +0200
Source: adonthell
Binary: adonthell
Architecture: source i386
Version: 0.3.4.cvs.20050813-2.2
Distribution: unstable
Urgency: medium
Maintainer: Gordon Fraser <gordon@debian.org>
Changed-By: Mohammed Adnène Trojette <adn+deb@diwi.org>
 adonthell  - A 2D graphical roleplaying game
Closes: 380756 381456 382202
 adonthell (0.3.4.cvs.20050813-2.2) unstable; urgency=medium
   * Non-maintainer upload with medium urgency.
   * Update to the New Python Policy (Closes: #380756)
      + debian/control
         - bump build-dependency on debhelper to (>=
         - remove build-dependency on python and python-dev
         - build-depend on python-dev (>= 2.3.5-11)
         - build-depend on python-support (>= 0.4)
         - depend on ${python:Depends}
      + debian/rules
         - build with $(shell pyversions -d) to make the package bin-NMUable
         - run dh_pythonsupport only (hence the >= 0.4 build-dep)
   * Build-Depend on libsdl1.2-dev, libsdl-ttf2.0-dev and libsdl-mixer1.2-dev instead
     of with the embedded version, add -lSDL_ttf to --with-py-libs in debian/rules
     and rebootstrap (Closes: #382202)
   * Work around #374062 using a patch from Julien Danjou (Closes: #381456)
   * Build-Depend on quilt for patch management and add adequate rules.
   * Bump Standards-Version to 3.7.2.
 14b46f9518cac9dfd48daa41cba0b82e 825 games optional adonthell_0.3.4.cvs.20050813-2.2.dsc
 e345629b50bff5242f951703ef42a520 96434 games optional adonthell_0.3.4.cvs.20050813-2.2.diff.gz
 527a3a61eec930f2bacebd1e15528773 261610 games optional adonthell_0.3.4.cvs.20050813-2.2_i386.deb

Version: GnuPG v1.4.5 (GNU/Linux)


--- End Message ---

Reply to: