[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libcurl3-dev depreciated (was: Bug#426393: asterisk: uninstallable due to dependancy on libcurl3)

On Sat, Jun 02, 2007 at 11:17:18AM +0100, Mark Purcell wrote:
> Dear libcurl team,

Hi Mark,

> When you depreciate libcurl3-dev all downstream dependant packages require 
> at least a rebuild, if not a reload to change the Build-Depends: from libcurl3-dev
> to libcurl4-dev.

RMs and I managed the transition, libcurl4-dev packages provide
libcurl3-dev counterparts for this reason.  I suppose they have issued
the required BinNMUs.

> At the minimum, could you send a courtesy email to all downstream packages (Cc:)
> so we know we need to upload after your library transition. Best option would be
> for you to file a bug report against those packages which will require a reload
> after your library/dev transition. Otherwise the users will trickle bug reports
> (attached) through to individual packages...

I am not so courtesy person when this has been already discussed on
-release, curl has been in experimental for quite some time and all
this is happening in unstable right after a stable release, where almost
every library with pending soname change is uploaded.

Tell me, why should I open so many bug reports myself when there are
lots of user able to do this themselves? ;)

Anyway I am going to open a curl mailing list on alioth so that
curl-dependant maintainers will be able to tune for such things.


-----[ Domenico Andreoli, aka cavok
 --[ http://www.dandreoli.com/gpgkey.asc
   ---[ 3A0F 2F80 F79C 678A 8936  4FEE 0677 9033 A20E BC50

Reply to: