[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#424654: centericq: links to libcurl4-openssl

Package: centericq
Version: 4.21.0-19+b2
Severity: serious
Justification: Policy 2.3

centericq is distributed under the GPL. OpenSSL, which is distributed
under a non-compatible license is linked to libcurl4-openssl. centericq
should use libcurl4-gnutls. Perhaps, changing the Build-Depends would
have avoided this binNMU situation.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.20-1-vserver-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages centericq depends on:
ii  centericq-common            4.21.0-19+b2 A text-mode multi-protocol instant
ii  libc6                       2.5-7        GNU C Library: Shared libraries
ii  libcurl4-openssl            7.16.2-3     Multi-protocol file transfer libra
ii  libgcc1                     1:4.1.2-6    GCC support library
ii  libgnutls13                 1.6.2-2      the GNU TLS library - runtime libr
ii  libgpg-error0               1.4-2        library for common error values an
ii  libgpgme11                  1.1.2-5      GPGME - GnuPG Made Easy
ii  libkrb53                    1.6.dfsg.1-4 MIT Kerberos runtime libraries
ii  libncurses5                 5.5-5        Shared libraries for terminal hand
ii  libssl0.9.8                 0.9.8e-4     SSL shared libraries
ii  libstdc++6                  4.1.2-6      The GNU Standard C++ Library v3

Versions of packages centericq recommends:
ii  elinks [www-browser]          0.11.1-1.4 advanced text-mode WWW browser
ii  epiphany-browser [www-browser 2.18.1-2   Intuitive GNOME web browser
ii  lynx [www-browser]            2.8.6-2    Text-mode WWW Browser
ii  sox                           13.0.0-1   Swiss army knife of sound processi

-- no debconf information

Reply to: