[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#413654: emacs-snapshot-nox: ps-print broken

Package: emacs-snapshot-nox
Version: 1:20070302-1
Severity: normal

When I run pr-ps-buffer-print on 1:20070302, printing fails.
However, on1:20070223, printing worked fine.

On *Message* buffer, ps-print stopped with following error:

ps-generate: Symbol's value s variable is void: ps-mark-code-directory

printing related .emacs.el entry is as follows:

(require 'ps-print)
(setq ps-print-color-p t)
(setq ps-multibyte-buffer 'non-latin-printer)
(setq ps-default-bg "white")
(setq ps-default-fg "black")

(require 'printing)
(setq pr-ps-name 'dricoh)
(setq pr-ps-printer-alist '((dricoh "lpr" nil "-P" "dricoh")
                            (sricoh "lpr" nil "-P" "sricoh")))
(setq pr-faces-p t)
(setq pr-file-duplex t)
(pr-update-menus t)

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-4-686
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=ANSI_X3.4-1968) (ignored: LC_ALL set to C)

Versions of packages emacs-snapshot-nox depends on:
ii  emacs-snapshot-bin-common   1:20070302-1 The GNU Emacs editor's shared, arc
ii  libasound2                  1.0.13-2     ALSA library
ii  libc6                       2.3.6.ds1-13 GNU C Library: Shared libraries
ii  libncurses5                 5.5-5        Shared libraries for terminal hand

emacs-snapshot-nox recommends no packages.

Versions of packages emacs-snapshot-common depends on:
ii  dpkg                          1.13.25    package maintenance system for Deb
ii  emacsen-common                1.4.17     Common facilities for all emacsen

Versions of packages emacs-snapshot-bin-common depends on:
ii  emacs-snapshot-common       1:20070302-1 The GNU Emacs editor's common infr
ii  libc6                       2.3.6.ds1-13 GNU C Library: Shared libraries
ii  liblockfile1                1.06.1       NFS-safe locking library, includes

Versions of packages emacsen-common depends on:
ii  bsdmainutils                  6.1.6      collection of more utilities from 

Versions of packages emacs-snapshot-nox is related to:
ii  dictionaries-common           0.70.12    Common utilities for spelling dict

-- no debconf information

Reply to: