[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#400923: (no subject)

On Tue, Dec 05, 2006 at 09:07:29AM -0500, Jeff Beaird wrote:
> Steve Langasek wrote:
> >The point is that, according to the bug submitter, programs being run
> >*under* multi-gnome-terminal don't have $DISPLAY set in their environment.
> >
> >It may indeed still not be an m-g-t bug, but at least it doesn't appear to
> >be a gdm bug.
> >
> I, too, doubt that it's a multi-gnome-terminal bug.  I just can't figure 
> out why when I type 'env' in the gnome-terminal window, I have several 
> more variables set than when I type 'env' in the multi-gnome-terminal 
> window.
> My guess is that it has something to do with m-g-t being a gnome1 app, 
> although I don't see how that'd make a difference.
> Thanks for your help,

Sorry for the delay.

I had a look at the source code for gnome-terminal. gnome-terminal is setting the
HOME environmental variable as well as some other variables. This explains why it's
working fine with -display.

I'll work on a patch for that.

GNU/Linux registered user #224950
Proud Egyptian GNU/Linux User Group <www.eglug.org> Member.
Life powered by Debian, Homepage: www.foolab.org
Don't send me any attachment in Micro$oft (.DOC, .PPT) format please
Read http://www.gnu.org/philosophy/no-word-attachments.html
Preferable attachments: .PDF, .HTML, .TXT
Thanx for adding this text to Your signature

Attachment: signature.asc
Description: Digital signature

Reply to: