[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#401677: mailscanner: MailScanner 4.55.10-1 missing DEPENDS on libsys-hostname-long-perl

Package: mailscanner
Version: 4.55.10-1
Severity: grave
Justification: renders package unusable

Mailscanner fails to start since upgrade. Manually running the daemon
gives error message:

Can't locate Sys/Hostname/Long.pm in @INC (@INC contains:
/usr/share/MailScanner /etc/perl /usr/local/lib/perl/5.8.8
/usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4
/usr/local/lib/perl/5.8.0 /usr/local/share/perl/5.8.0 .
/usr/share/MailScanner) at /usr/sbin/MailScanner line 67.

Installing package libsys-hostname-long-perl resolves this error,
therefore please append this package as a DEPENDS to the MailScanner


-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (900, 'unstable'), (500, 'testing'), (200, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=en_GB, LC_CTYPE=en_GB (charmap=ISO-8859-1) (ignored: LC_ALL set to en_GB)

Versions of packages mailscanner depends on:
ii  debconf [debconf-2.0]   1.5.9            Debian configuration management sy
ii  exim4                   4.63-11          metapackage to ease exim MTA (v4) 
ii  exim4-daemon-heavy [mai 4.63-11          exim MTA (v4) daemon with extended
ii  libarchive-zip-perl     1.16-1           Module for manipulation of ZIP arc
ii  libcompress-zlib-perl   1.42-2           Perl module for creation and manip
ii  libconvert-binhex-perl  1.119+pristine-1 Perl5 module for extracting data f
ii  libconvert-tnef-perl    0.17-5           Perl module to read TNEF files
ii  libdbd-sqlite3-perl     1.13-1.1         Perl DBI driver with a self-contai
ii  libfilesys-df-perl      0.92-2           Module to obtain filesystem disk s
ii  libhtml-parser-perl     3.55-1           A collection of modules that parse
ii  libmime-perl            5.420-1          Perl5 modules for MIME-compliant m
ii  libnet-cidr-perl        0.11-1           Manipulate IPv4/IPv6 netblocks in 
ii  libsys-syslog-perl      0.18-2           Perl interface to the UNIX syslog(
ii  perl                    5.8.8-6.1        Larry Wall's Practical Extraction 
ii  spamassassin            3.1.7-1          Perl-based spam filter using text 
ii  ucf                     2.0017           Update Configuration File: preserv
ii  unzip                   5.52-9           De-archiver for .zip files

Versions of packages mailscanner recommends:
ii  ncftp                         2:3.2.0-1  A user-friendly and well-featured 
ii  tnef                          1.4.3-1    Tool to unpack MIME application/ms
ii  wget                          1.10.2-2   retrieves files from the web

-- debconf information:
* mailscanner/v3_upgrade: Don't upgrade

Reply to: