[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#287494: marked as done (lopster: FTBFS (amd64/gcc-4.0): invalid lvalue in assignment)

Your message dated Tue, 05 Sep 2006 14:34:22 -0700
with message-id <E1GKiYo-00026u-1p@spohr.debian.org>
and subject line Bug#287494: fixed in lopster 1.2.2-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: lopster
Severity: normal
Tags: patch

When building 'lopster' on amd64 with gcc-4.0,
I get the following error:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include    -O2 -ffunction-sections -W -Wall -D_GNU_SOURCE -c log.c
log.c: In function 'close_logs':
log.c:151: error: invalid lvalue in assignment
log.c: In function 'on_log_delete':
log.c:608: warning: cast from pointer to integer of different size
make[3]: *** [log.o] Error 1
make[3]: Leaving directory `/lopster-'

With the attached patch 'lopster' can be compiled
on amd64 using gcc-4.0.

Andreas Jochens

diff -urN ../tmp-orig/lopster- ./src/log.c
--- ../tmp-orig/lopster-	2003-03-04 21:08:57.000000000 +0100
+++ ./src/log.c	2004-12-28 10:10:05.000000000 +0100
@@ -148,7 +148,7 @@
-  net?net->logs:other_logs = NULL;
+  if (net) net->logs = NULL; else other_logs = NULL;
 void log_file_destroy(log_file_t* lf) {

--- End Message ---
--- Begin Message ---
Source: lopster
Source-Version: 1.2.2-4

We believe that the bug you reported is fixed in the latest version of
lopster, which is due to be installed in the Debian FTP archive:

  to pool/main/l/lopster/lopster_1.2.2-4.diff.gz
  to pool/main/l/lopster/lopster_1.2.2-4.dsc
  to pool/main/l/lopster/lopster_1.2.2-4_i386.deb
  to pool/main/l/lopster/lopster_1.2.2.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 287494@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Francesco Namuri <francesco@namuri.it> (supplier of updated lopster package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue,  5 Sep 2006 11:20:14 +0200
Source: lopster
Binary: lopster
Architecture: source i386
Version: 1.2.2-4
Distribution: unstable
Urgency: low w
Maintainer: Francesco Namuri <francesco@namuri.it>
Changed-By: Francesco Namuri <francesco@namuri.it>
 lopster    - A Napster client using the GTK UI
Closes: 262522 287494 287494 306017 366006
 lopster (1.2.2-4) unstable; urgency=low
   * modified debian/rules, now use "dh_install" instead "install" and added
     "dh_desktop" to register .desktop files
 lopster (1.2.2-3) unstable; urgency=low
   * Fixed packaging, using dpatch and removing modifies to upstream's directory
 lopster (1.2.2-2) unstable; urgency=low
   * Added .desktop and icon file for menu compliant with freedesktop
 lopster (1.2.2-1) unstable; urgency=low
   * New upstream release (Closes: #306017, #262522, #366006)
 lopster ( unstable; urgency=low
   * QA Upload (ACK NMU; Closes: #287494)
   * Set Maintainer to QA Group, Orphaned: #366006
   * Use higher debhelper compat, depend on at least dh 4.0
   * Use dh_installman
   * Update debian/menu
   * Remove debian/substvars from diff.
   * Conforms with latest Standards Version 3.7.2
 lopster ( unstable; urgency=lo w
   * Non-maintainer upload.
   * src/log.c: Apply patch from Andreas Jochens to fix FTBFS with
     GCC 4.0 (Closes: #287494).
 dd59f2497d200d6776d85b7d482c1703 611 net optional lopster_1.2.2-4.dsc
 ae857116eddd01f1f7d2769908a142c0 630325 net optional lopster_1.2.2.orig.tar.gz
 d8f8bfb27a0c9a672bba05faa3a7c7c3 5547 net optional lopster_1.2.2-4.diff.gz
 90c5baee245b311f997fa9a7ae34a087 668406 net optional lopster_1.2.2-4_i386.deb

Version: GnuPG v1.4.5 (GNU/Linux)


--- End Message ---

Reply to: