[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#385893: CVE-2006-4262: Cscope Buffer Overflow Vulnerabilities

Package: cscope
Severity: grave
Tags: security patch
Justification: user security hole

Some vulnerabilities have been found in cscope:

Multiple buffer overflows in cscope 15.5 and earlier allow
user-assisted attackers to cause a denial of service (crash) and
possibly execute arbitrary code via multiple vectors including (1) a
long pathname that is not properly handled during file list parsing,
(2) long pathnames that result from path variable expansion such as
tilde expansion for the HOME environment variable, and (3) a long -f
(aka reffile) command line argument.

The secunia advisory points to some patches:

Reply to: