[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#380955: Python transition (#2): you are building a private python module !

Package: qtorrent
Version: 2.9.1-5
Severity: important

  Hi, your package has been detected as generating a (for most of that
mass bug fill: private) python module/extension that may need an upgrade
to the new Python Policy[1].

  A wiki page[2] explains what has to be done to upgrade your packages
to the new Policy. This bug may be a false positive, in that case,
please just close the bug.

  This bug is part of a mass bug filling, and its severity will be
raised to serious when python will default to python2.4 (which should
happend on tomorrow - Wed 2nd of July). Please note that this bug (even
not being RC) falls under the 0-day NMU policy.

  [1] http://lists.debian.org/debian-devel-announce/2006/06/msg00009.html
  [2] http://wiki.debian.org/DebianPython/NewPolicy
      especially "Notes for packages with private modules/extensions"

Special Notes

  * embedded interpreters: You don't *need* to do anything for your
    package, though using XS/XB-Python-Version is much appreciated as it
    helps tracking your package for binNMUs when python2.4 will become

  * if you need help updating your package, you can either:
     - mail debian-python@lists.debian.org ,
     - tag your bug + help ,
     - come on #debian-python/OFTC.

Reply to: