[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#338643: marked as done (ofpath issue with SATA disks)

Your message dated Tue, 11 Jul 2006 00:58:48 +0200
with message-id <20060710225848.GB2632@roxor.cx>
and subject line ofpath issue with SATA disks
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: 2005-11-07 debian-testing-powerpc-binary-1.iso from cdimage.debian
uname -a: Linux (none) 2.6.12-1-powerpc64 #1 SMP Tue Sep 27 15:20:16 UTC 2005 ppc64 unknown
Date: 2005 11 10/11
      install, from local CD

Machine: Powermac G5 Processor: single 1.8
Memory: 1.25GB
Root Device: sda6
Root Size/partition table: N/A

Output of lspci and lspci -n:

lspci (from a gentoo install CD - of course, that can't install either)

0000:f0:0b.0 Host bridge: Apple Computer Inc. U3L AGP Bridge
0000:f0:10.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200 Ultra] (rev a1)
0001:00:01.0 PCI bridge: Apple Computer Inc. Shasta PCI Bridge
0001:00:02.0 PCI bridge: Apple Computer Inc. Shasta PCI Bridge
0001:00:03.0 PCI bridge: Apple Computer Inc. Shasta PCI Bridge
0001:01:07.0 Class ff00: Apple Computer Inc. Shasta Mac I/O
0001:01:0b.0 USB Controller: NEC Corporation USB (rev 43)
0001:01:0b.1 USB Controller: NEC Corporation USB (rev 43)
0001:01:0b.2 USB Controller: NEC Corporation USB (rev 43)
0001:02:0c.0 IDE interface: Broadcom (formerly ServerWorks) K2 SATA
0001:02:0d.0 Class ff00: Apple Computer Inc. Shasta IDE
0001:02:0e.0 Firewire (IEEE 1394): Apple Computer Inc. Shasta Firewire
0001:03:0f.0 Ethernet controller: Apple Computer Inc. Shasta (Sun GEM)

lspci -n

0000:f0:0b.0 Class 0600: 106b:0058
0000:f0:10.0 Class 0300: 10de:0321 (rev a1)
0001:00:01.0 Class 0604: 106b:0053
0001:00:02.0 Class 0604: 106b:0054
0001:00:03.0 Class 0604: 106b:0055
0001:01:07.0 Class ff00: 106b:004f
0001:01:0b.0 Class 0c03: 1033:0035 (rev 43)
0001:01:0b.1 Class 0c03: 1033:0035 (rev 43)
0001:01:0b.2 Class 0c03: 1033:00e0 (rev 04)
0001:02:0c.0 Class 0101: 1166:0240
0001:02:0d.0 Class ff00: 106b:0050
0001:02:0e.0 Class 0c00: 106b:0052
0001:03:0f.0 Class 0200: 106b:0051

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]


(The network hardware appeared to be configured, but it couldn't get
a dhcp lease or contact a mirror, and my other boxes couldn't ping it.
According to BenH, my PHY needs a 2.6.14 kernel, which is why I tried
the "full" CD)

 Yaboot-installer fails to detect the OF pathes for /dev/sda2 (bootstrap)
and /dev/sda3 (os) and declines to install.

yaboot-installer: info: probed: /dev/discs/disc0/part3:Mac OS X:MacOSX:macosx yaboot-installer: debug: mapped: /dev/sda3 kernel: ioctl32(nvsetenv:3998): Unknown cmd fd(7) cmd(20007043){' '} arg(00000000) on /dev/nvram yaboot-installer: mkofboot: Finding OpenFirmware device path to `/dev/sda2'... yaboot-installer: ofpath: /proc/device-tree is broken. Do not use BootX to boot, use yaboot. yaboot-installer: ofpath: The yaboot HOWTO can be found here: http://www.alaska.net/~erbenson/doc yaboot-installer: mkofboot: Unable to find OpenFirmware path for boot=/dev/sda2 yaboot-installer: mkofboot: Please add ofboot=<path> where <path> is the OpenFirmware path to /dev/sda2 to /etc/yaboot.conf [...snip similar for /dev/sda3...] yaboot-installer: mkofboot: Try specifying the real OpenFirmware path for macos=/dev/sda3 in /etc/yaboot.conf yaboot-installer: error: mkofboot failed with exit status 1

 das eine Mal als Tragödie, das andere Mal als Farce

--- End Message ---
--- Begin Message ---

I cannot reproduce it anymore. Please feel free to reopen it if it
still happens which I sincerely doubt...

((__,-"""-,__))  Aurélien GÉRÔME           .---.
 `--)~   ~(--`   Free Software Developer  /     \
.-'(       )`-.  Unix Sys & Net Admin     \.@-@./
`~~`@)   (@`~~`                           /`\_/`\
    |     |            .''`.             //  _  \\
    |     |           : :'  :           | \     )|_
    (8___8)           `. `'`           /`\_`>  <_/ \
     `---`              `-             \__/'---'\__/
BOFH excuse #63: not properly grounded, please bury computer

Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: