[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#330728: marked as done (c2hs: doc/tests/Makefile problem)

Your message dated Sun, 02 Jul 2006 07:23:06 +0200
with message-id <1151817787.5456.19.camel@nebula.arriesoft.nl>
and subject line mistaken NMU upload
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: c2hs
Version: 0.13.6-2
Severity: minor
Tags: patch


thanks for maintaining this package.

As I just tried to get c2hs rebuilt for ubuntu (which worked well apart from
weakening some build-deps), I recognized that the shipped tests under
/usr/share/doc don't compile with the Makefile. So I wrote a tiny patch to fix
this problem. Maybe this is useful for you.


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12build1
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)
diff -Nur c2hs-0.13.6/c2hs/tests/Makefile c2hs-0.13.6.new/c2hs/tests/Makefile
--- c2hs-0.13.6/c2hs/tests/Makefile	2005-09-27 13:39:52.000000000 +0200
+++ c2hs-0.13.6.new/c2hs/tests/Makefile	2005-09-28 23:24:02.000000000 +0200
@@ -1,7 +1,8 @@
-include ../../mk/config.mk
+#include ../../mk/config.mk
-HCFLAGS= -package lang -fglasgow-exts -i../lib -L../lib -lc2hs
-C2HS   = ../c2hs
+HCFLAGS= -package lang -package c2hs -fglasgow-exts -lc2hs
+C2HS   = c2hs
+HC     ?= ghc6
 PRGMS = simple calls enums pointer structs marsh cpp

--- End Message ---
--- Begin Message ---
Version: 0.13.6-3

This bug was already fixed in version 0.13.6-3, but this upload was
mistaken for a NMU. Thus closing it 'by hand'.

Greetings Arjan

Attachment: signature.asc
Description: Dit berichtdeel is digitaal ondertekend

--- End Message ---

Reply to: