[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#369726: xcircuit 3.6.24-1 unusable on amd64

Michael -

On Thu, Jun 01, 2006 at 10:31:41AM +0200, Michael Ablassmeier wrote:
> On Wed, May 31, 2006 at 09:47:11PM -0700, Steve Langasek wrote:
> > The attached patch fixes [typedef void (*XwStrProc)], and gives
> > me a minimally-usable package on amd64.

I can confirm this.  Thanks, Steve!

> there is a discussion about a few other outstanding issues on the
> xcircuit-dev [1] list, lets see what comes up. Im going to prepare a QA
> Upload as things settle down. Thanks for your patch, im forwarding it 
> to upstreams.

I'd say the minimum step is to put in this patch, but
also include a NEWS item that files produced by this
version (and 3.6.24-1) of xcircuit can not be read by
older versions of xcircuit.  Specifically, any version
before ~3.1.38, including 3.1.19-1 in sarge.

Could a NEWS item also request feedback from xcircuit
users on a possible change from python/Xw to tcl/Tk?
Or is it better to just plan on parallel xcircuit and
xcircuit-tcl packages?

I have a large-ish language cleanup patch I am working
on, that I will push upstream to Tim.  But I don't think
that fundamentally affects the situation here.

    - Larry

Reply to: