[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#369443: no /usr/X11R6 directory makes pornview segfault on startup

Package: pornview
Version: 0.2pre1-5
Severity: grave
Justification: renders package unusable

I am using a fresh debian install, so I use Xorg7, then I have a quite empty /usr/X11R6/ directory,
here are the latest strace output before SIGSEGV.

open("/usr/share/pixmaps/gnome/cursors/32e49c8b393e725c8f6b5fc0203e4fff", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/pixmaps/gnome/index.theme", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/X11R6/lib/X11/icons/gnome/cursors/32e49c8b393e725c8f6b5fc0203e4fff", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/X11R6/lib/X11/icons/gnome/index.theme", O_RDONLY) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Process 3532 detached

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages pornview depends on:
ii  libatk1.0-0               1.11.4-2       The ATK accessibility toolkit
ii  libc6                     2.3.6-9        GNU C Library: Shared libraries
ii  libglib2.0-0              2.10.3-1       The GLib library of C routines
ii  libgtk2.0-0               2.8.17-2       The GTK+ graphical user interface 
ii  libpango1.0-0             1.12.1-3       Layout and rendering of internatio
ii  libpng12-0                1.2.8rel-5.1   PNG library - runtime
ii  libx11-6                  2:1.0.0-6      X11 client-side library
ii  libxext6                  1:1.0.0-4      X11 miscellaneous extension librar
ii  libxine1                  1.1.1-1.1      the xine video/media player librar
ii  xlibs                     6.9.0.dfsg.1-6 X Window System client libraries m
ii  zlib1g                    1:1.2.3-11     compression library - runtime

pornview recommends no packages.

-- no debconf information

Reply to: