[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#367077: installwatch: Segmentation faults on mkdir, cp

Package: installwatch
Version: 0.6.3-2
Severity: grave
Justification: renders package unusable

Whenever I run checkinstall, I get a segmentation fault when it invokes installwatch. It used to work until around 2 - 4 weeks ago. This fault renders checkinstall useless.

The output on the console is, for example:

Copying documentation directory...
/var/tmp/pBcFXBogLSoZdCkGjJOn/installscript.sh: line 14: 22439
Segmentation fault      mkdir -p "/usr/share/doc/qt41"

The fault occurs even if the directory being created by mkdir already

I tried creating a little script and manually running installwatch. The
commands 'mkdir' and 'cp' both fail with a segmentation fault, whereas
'echo' doesn't.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-k7
Locale: LANG=en_GB, LC_CTYPE=en_GB (charmap=ISO-8859-1)

Versions of packages installwatch depends on:
ii  libc6                         2.3.6-7    GNU C Library: Shared libraries

installwatch recommends no packages.

-- no debconf information

Reply to: