[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#344942: doxymacs: Fails to install with "!! File error (("Cannot open load file" "url"))"

Frank Lichtenheld <djpig@debian.org> writes:

> On Tue, Dec 27, 2005 at 07:20:10PM +0000, Roger Leigh wrote:
>> I suggest depending upon w3-el-e21 unconditionally, which would make
>> things robust, even if it's not strictly required in all cases.
>> xemacs21 already depends upon xemacs21-basesupport, so
>> Depends: libc6 (>= 2.3.5-1), libxml2 (>= 2.6.21), zlib1g (>= 1:1.2.1),
>> emacs21 | emacsen, w3-el-e21, w3-url-e21
>> might be better.  Caveat: I don't claim to be an emacs packaging expert,
>> so this does need checking!
> While this certainly would fix the bug, it would mean that you have to
> install emacs21 in order to be able to install doxymacs (because
> w3-url-e21 depends on it) which is a rather big penalty if one does only
> use xemacs...
> Another possibility would be to unfold the emacsen dependency and
> change it to:
> Depends: (...shlibs...), w3-el-e21 | xemacs21 | emacs-snapshot
> Since w3-el-21 depends on w3-url-e21 and emacs21, these are
> automatically included.

This looks like a much cleaner and more robust solution.


Roger Leigh
                Printing on GNU/Linux?  http://gutenprint.sourceforge.net/
                Debian GNU/Linux        http://www.debian.org/
                GPG Public Key: 0x25BFB848.  Please sign and encrypt your mail.

Attachment: pgp0FLYt5zSdH.pgp
Description: PGP signature

Reply to: