[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#355164: ilisp: ilisp.el defaults to guile1.4 for the guile interpreter

Package: ilisp
Version: 5.12.0+cvs.2004.12.26
Severity: minor

I have only guile 1.6 and not guile 1.4 installed and whenever I start
a guile process in emacs using ilisp I get the error that
/usr/bin/guile1.4 does not exist.  It seems to be because the
following line (line 80) in /etc/ilisp/ilisp.el uses 1.4 for the guile
interpreter when it sets ilisp-site-hook:

	 (setq guile-program "/usr/bin/guile1.4")

If I set it to /usr/bin/guile it will start guile 1.6 for me without
an error.  It seems to me that with guile 1.8 having been just
released and the programs I know about (gnucash, gnotime) that use
guile using 1.6 rather than 1.4 now, it would be better to default
this to 1.6, or whatever /usr/bin/guile is, and let users override it
if they have a need for 1.4 or a different version.  Ideally, there
would be an emacs customization for setting which interpreter to use
for each lisp dialect.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14-2-powerpc
Locale: LANG=en_CA, LC_CTYPE=en_CA (charmap=ISO-8859-1)

Versions of packages ilisp depends on:
ii  common-lisp-controller        4.27       This is a Common Lisp source and c
ii  debconf [debconf-2.0]         1.4.71     Debian configuration management sy
ii  emacsen-common                1.4.17     Common facilities for all emacsen

Versions of packages ilisp recommends:
ii  ilisp-doc          5.12.0+cvs.2004.12.26 Documentation for ILISP package

-- debconf information:
* ilisp/fsf-compliant: false

Reply to: