[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#352168: rxvt-unicode: Xft fonts broken with upgrade

Package: rxvt-unicode
Version: 7.5-1
Severity: important

I normally use Xft fonts with urxvt to get antialiasing. Upon upgrade
urxvt refuses to run. If I remove the Xft font settings from my
.Xresourses file then it runs again. However just specifying an Xft font
causes it to fail to start. I have bitstream vera sans mono installed,
and have been using that with previous releases. This is the startup
example given in the man page. It fails as shown:

$ xlsfonts | grep -i vera.sans.mono.medium.*iso10646-1
-bitstream-bitstream vera sans mono-medium-o-normal--0-0-0-0-c-0-iso10646-1
-bitstream-bitstream vera sans mono-medium-o-normal--0-0-0-0-m-0-iso10646-1
-bitstream-bitstream vera sans mono-medium-r-normal--0-0-0-0-c-0-iso10646-1
-bitstream-bitstream vera sans mono-medium-r-normal--0-0-0-0-m-0-iso10646-1
$ urxvt -fn "xft:Bitstream Vera Sans Mono:pixelsize=15"
urxvt: unable to load base fontset, please specify a valid one using
-fn, aborting.

Note that all other default codepages show up for the font as well, just
that I did not want to spam them all here. Running with LANG=C does not
change the symptoms. Other -fn settings work. Including:

$ urxvt -fn "-bitstream-bitstream vera sans

But no anti-aliasing occurs.

urxvt does seem to be linked to Xft as expected.

$ ldd /usr/bin/urxvt
 linux-gate.so.1 =>  (0xffffe000)
 libXft.so.2 => /usr/lib/libXft.so.2 (0xb7f31000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7f02000)
 libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0xb7eec000)
 libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xb7e21000)
 libperl.so.5.8 => /usr/lib/libperl.so.5.8 (0xb7d01000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7cfc000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7cd6000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7cc3000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7b8d000)
 libcrypt.so.1 => /lib/tls/i686/cmov/libcrypt.so.1 (0xb7b5f000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7b54000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7ae6000)
 libz.so.1 => /usr/lib/libz.so.1 (0xb7ad2000)
 libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7ac9000)
 libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7aa9000)
 libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xb7a9b000)
 /lib/ld-linux.so.2 (0xb7f56000)

It's not clear from the bug reports:

* #348666: rxvt-unicode: default font lost with upgrade ?
* #348697: rxvt-unicode: forget to load the app-defaults file

but they might be related to this issue instead of a separate
app-defaults issue?

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages rxvt-unicode depends on:
ii base-passwd    3.5.11         Debian base system master password
ii libc6          2.3.5-13       GNU C Library: Shared libraries an
ii libfontconfig1 2.3.2-1.1      generic font configuration library
ii libgcc1        1:4.0.2-8      GCC support library
ii libperl5.8     5.8.8-1        Shared Perl library
ii libx11-6       6.9.0.dfsg.1-4 X Window System protocol client li
ii libxft2      FreeType-based font drawing librar
ii libxpm4        6.9.0.dfsg.1-4 X pixmap library
ii ncurses-base   5.5-1          Descriptions of common terminal ty

rxvt-unicode recommends no packages.

-- no debconf information
Tim Riker - http://Rikers.org/ - TimR@Debian.org
Embedded Linux Technologist - http://eLinux.org/
BZFlag maintainer - http://BZFlag.org/ - for fun!

Reply to: