[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#339349: pgperl

Package: pgperl
Version: 2.18-5

I can't generate PNG files using the pgperl package as supplied in 

(pgtest.pl is attached)
orchestra ~ % perl pgtest.pl
libpng warning: Application was compiled with png.h from libpng-1.2.5
libpng warning: Application  is  running with png.c from libpng-1.0.18
libpng error: Incompatible libpng version in application and library
PGPLOT /png: error in libpng while writing file test.png, plotting disabled

I am not really sure why this error occurs since the pgperl package 
appears to be built with libpng 1.0 (it build-requires libpng2-dev) and 
is explicitly linked against it.

% ldd /usr/lib/perl5/auto/PGPLOT/PGPLOT.so
        libpgplot.so.5 => /usr/lib/libpgplot.so.5 (0x40041000)
        libpng10.so.0 => /usr/lib/libpng10.so.0 (0x400c9000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400ed000)
        libg2c.so.0 => /usr/lib/libg2c.so.0 (0x401b4000)
        libm.so.6 => /lib/libm.so.6 (0x401d2000)
        libc.so.6 => /lib/libc.so.6 (0x401f4000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x40327000)
        libz.so.1 => /usr/lib/libz.so.1 (0x40330000)
        libdl.so.2 => /lib/libdl.so.2 (0x40343000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

In any case, if I change the Build-Depends: for pgperl to instead use
libpng12-dev, as in the enclosed patch, and rebuild the package, I can
generate PNGs as expected.


Bret Andrew Martin                 Harvard Medical School
Senior Research Systems Architect  Research Information Technology Group
bret_martin@hms.harvard.edu        http://ritg.med.harvard.edu


use PDL;
use PDL::Graphics::PGPLOT;


$win = dev("test.png/PNG");

@x = (1, 3, 4, 5);
@y = (5, 6, 8, 1);

$a = pdl @x;
$b = pdl @y;

line ($a, $b, {COLOUR => CYAN, SYMBOL => 18});
--- pgperl-2.18/debian/control  2005-11-15 12:32:40.000000000 -0500
+++ pgperl-2.18/debian/control.orig     2005-11-15 12:38:35.000000000 -0500
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian QA Group <packages@qa.debian.org>
 Standards-Version: 3.5.6
-Build-Depends: debhelper (>> 4.1), perl (>> 5.8), pgplot5 (> 5.2.2),
g77, xlibs-dev, libpng12-dev
+Build-Depends: debhelper (>> 4.1), perl (>> 5.8), pgplot5 (> 5.2.2),
g77, xlibs-dev, libpng2-dev
 Package: pgperl
 Architecture: any

Reply to: