[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#311852: marked as done (python-gtk-1.2: pygtk.requires("1.2") should be replaced with the pygtk.require("1.2"))

Your message dated Sat, 08 Oct 2005 10:32:09 -0700
with message-id <E1EOIYL-0006gs-00@spohr.debian.org>
and subject line Bug#311852: fixed in python-gnome 1.4.5-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 3 Jun 2005 20:04:15 +0000
>From dron@ak4719.spb.edu Fri Jun 03 13:04:15 2005
Return-path: <dron@ak4719.spb.edu>
Received: from vlan3.cgp.pu.ru (cgp.pu.ru) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DeIOs-0006m3-00; Fri, 03 Jun 2005 13:04:14 -0700
Received: from wg.pu.ru ([] verified)
  by cgp.pu.ru (CommuniGate Pro SMTP 4.2.8)
  with ESMTP id 68583336 for submit@bugs.debian.org; Sat, 04 Jun 2005 00:04:12 +0400
Received: (from uucp@localhost)
	by wg.pu.ru (8.9.1a/8.9.1) with UUCP id UAA08499
	for submit@bugs.debian.org; Fri, 3 Jun 2005 20:04:12 GMT
Received: from ak4719.spb.edu (localhost [])
	by ak4719.spb.edu (8.13.3/8.13.3/Debian-6) with ESMTP id j53JvwOW032655
	for <submit@bugs.debian.org>; Fri, 3 Jun 2005 23:57:58 +0400
Received: (from dron@localhost)
	by ak4719.spb.edu (8.13.3/8.13.3/Submit) id j53Jvs6k032644;
	Fri, 3 Jun 2005 23:57:54 +0400
Message-Id: <200506031957.j53Jvs6k032644@ak4719.spb.edu>
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Andrey Kiselev <dron@ak4719.spb.edu>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: python-gtk-1.2: pygtk.requires("1.2") should be replaced with the
X-Mailer: reportbug 3.8
Date: Fri, 03 Jun 2005 23:57:54 +0400
X-Virus-Scanned: ClamAV version 0.84, clamav-milter version 0.84e on ak4719
X-Virus-Status: Clean
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: python-gtk-1.2
Version: 0.6.12-2.1
Severity: normal


The call pygtk.requires("1.2") in all sample scripts in the
documentation directory should be replaced with the
pygtk.require("1.2"). That is very easy to verify, just look inside the
/usr/lib/python2.3/site-packages/pygtk.py module, there are two
functions, one of them called require(), not requires().

In the current state all samples are completely unusable.

Best regards,

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux
Locale: LANG=ru_RU.KOI8-R, LC_CTYPE=ru_RU.KOI8-R (charmap=KOI8-R)

Versions of packages python-gtk-1.2 depends on:
ii  libc6                    2.3.2.ds1-21    GNU C Library: Shared libraries an
ii  libgdk-pixbuf2           0.22.0-7        The GdkPixBuf image library, gtk+ 
ii  libglib1.2               1.2.10-9        The GLib library of C routines
ii  libgtk1.2                1.2.10-17       The GIMP Toolkit set of widgets fo
ii  libx11-6                 4.3.0.dfsg.1-10 X Window System protocol client li
ii  libxext6                 4.3.0.dfsg.1-10 X Window System miscellaneous exte
ii  libxi6                   4.3.0.dfsg.1-10 X Window System Input extension li
ii  python                   2.3.4-5         An interactive high-level object-o
ii  xlibs                    4.3.0.dfsg.1-10 X Keyboard Extension (XKB) configu

-- no debconf information

Received: (at 311852-close) by bugs.debian.org; 8 Oct 2005 17:41:28 +0000
>From katie@spohr.debian.org Sat Oct 08 10:41:28 2005
Return-path: <katie@spohr.debian.org>
Received: from katie by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1EOIYL-0006gs-00; Sat, 08 Oct 2005 10:32:09 -0700
From: Matej Vela <vela@debian.org>
To: 311852-close@bugs.debian.org
X-Katie: $Revision: 1.56 $
Subject: Bug#311852: fixed in python-gnome 1.4.5-4
Message-Id: <E1EOIYL-0006gs-00@spohr.debian.org>
Sender: Archive Administrator <katie@spohr.debian.org>
Date: Sat, 08 Oct 2005 10:32:09 -0700
Delivered-To: 311852-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 2

Source: python-gnome
Source-Version: 1.4.5-4

We believe that the bug you reported is fixed in the latest version of
python-gnome, which is due to be installed in the Debian FTP archive:

  to pool/main/p/python-gnome/python-gdk-imlib-1.2_0.6.12-4_i386.deb
  to pool/main/p/python-gnome/python-glade-1.2_0.6.12-4_i386.deb
  to pool/main/p/python-gnome/python-gnome-1.2_1.4.5-4_i386.deb
  to pool/main/p/python-gnome/python-gnome_1.4.5-4.diff.gz
  to pool/main/p/python-gnome/python-gnome_1.4.5-4.dsc
  to pool/main/p/python-gnome/python-gtk-1.2_0.6.12-4_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 311852@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matej Vela <vela@debian.org> (supplier of updated python-gnome package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat,  8 Oct 2005 19:23:44 +0200
Source: python-gnome
Binary: python-gtk-1.2 python-gdk-imlib-1.2 python-glade-1.2 python-gnome-1.2
Architecture: source i386
Version: 1.4.5-4
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
 python-gdk-imlib-1.2 - GTK gdk_imlib support module for Python
 python-glade-1.2 - Put a bit of python code behind interfaces built with GLADE
 python-gnome-1.2 - PyGNOME -- Python bindings for GNOME
 python-gtk-1.2 - GTK support module for Python
Closes: 253749 311852 326514
 python-gnome (1.4.5-4) unstable; urgency=low
   * QA upload.
   * Automatically update config.sub and config.guess from autotools-dev.
     Closes: 326514.
   * Add `Build-Conflicts: gtkglarea-dev' to prevent gtkgl from being built
     accidentally.  Closes: #253749.
   * debian/README.Debian, debian/fix_examples.py: The function provided by
     pygtk is `require' rather than `requires'.  Closes: #311852.
   * Remove `Uploaders'.
   * Conforms to Standards version 3.6.2.
 518d5887ac66d7ad69c26b700ef8a7eb 957 python optional python-gnome_1.4.5-4.dsc
 52c1d0f2b60be9014c44afbdb19df732 11875 python optional python-gnome_1.4.5-4.diff.gz
 562439bc22ea54297009ad6eee1526d7 145038 python optional python-gnome-1.2_1.4.5-4_i386.deb
 08e1c67d7b96211506d0ebbca54047af 263418 python optional python-gtk-1.2_0.6.12-4_i386.deb
 7e05e44e4bb33f7a2dae066d44a1cbf4 27982 python optional python-glade-1.2_0.6.12-4_i386.deb
 67a75d312ddc374086d2e357bbd491e2 19806 python optional python-gdk-imlib-1.2_0.6.12-4_i386.deb

Version: GnuPG v1.4.2 (GNU/Linux)


Reply to: