[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#327303: marked as done (libgtk-perl: FTBFS: Failed to satisfy Build-Depends dependency: xlibmesa-dev)



Your message dated Fri, 09 Sep 2005 05:17:04 -0700
with message-id <E1EDhoW-0003Cn-00@spohr.debian.org>
and subject line Bug#327303: fixed in libgtk-perl 0.7009-5
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 9 Sep 2005 05:47:02 +0000
>From aj@andaco.de Thu Sep 08 22:47:02 2005
Return-path: <aj@andaco.de>
Received: from c129205.adsl.hansenet.de (localhost.localdomain) [213.39.129.205] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1EDbj4-00076f-00; Thu, 08 Sep 2005 22:47:02 -0700
Received: from aj by localhost.localdomain with local (Exim 4.52)
	id 1EDbj2-0007ym-Tl; Fri, 09 Sep 2005 07:47:00 +0200
To: Debian Bug Tracking System <submit@bugs.debian.org>
From: Andreas Jochens <aj@andaco.de>
Subject: libgtk-perl: FTBFS: Failed to satisfy Build-Depends dependency: xlibmesa-dev
Message-Id: <E1EDbj2-0007ym-Tl@localhost.localdomain>
Date: Fri, 09 Sep 2005 07:47:00 +0200
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libgtk-perl
Version: 0.7009-4
Severity: serious
Tags: patch

When building 'libgtk-perl' in a clean 'unstable' chroot,
I get the following error:

Building libgtk-perl unstable main amd64...
Reading package lists...
Building dependency tree...
Package xlibmesa-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libglu1-xorg-dev xlibmesa-gl-dev
E: Package xlibmesa-dev has no installation candidate
E: Failed to satisfy Build-Depends dependency for libgtk-perl: xlibmesa-dev

Please change the Build-Depends to 'xlibmesa-gl-dev' in debian/control.

Regards
Andreas Jochens

diff -urN ../tmp-orig/libgtk-perl-0.7009/debian/control ./debian/control
--- ../tmp-orig/libgtk-perl-0.7009/debian/control	2005-09-09 05:40:42.000000000 +0000
+++ ./debian/control	2005-09-09 05:40:39.000000000 +0000
@@ -4,7 +4,7 @@
 Maintainer: Debian QA Group <packages@qa.debian.org>
 Standards-Version: 3.6.2
 Build-Conflicts: libgtkhtml-dev
-Build-Depends: debhelper (>> 4.1), perl (>> 5.8.1), gtkglarea5-dev, libgnomeprint-dev, libcapplet1-dev, libgdk-pixbuf-gnome-dev, libggi2-dev, libgii0-dev, libglade-gnome0-dev, libunicode-dev, xlibmesa-dev, libxml-parser-perl, libxml-writer-perl, libzvt-dev, libgtkxmhtml-dev
+Build-Depends: debhelper (>> 4.1), perl (>> 5.8.1), gtkglarea5-dev, libgnomeprint-dev, libcapplet1-dev, libgdk-pixbuf-gnome-dev, libggi2-dev, libgii0-dev, libglade-gnome0-dev, libunicode-dev, xlibmesa-gl-dev, libxml-parser-perl, libxml-writer-perl, libzvt-dev, libgtkxmhtml-dev
 
 Package: libgtk-perl
 Architecture: any

---------------------------------------
Received: (at 327303-close) by bugs.debian.org; 9 Sep 2005 12:19:01 +0000
>From katie@spohr.debian.org Fri Sep 09 05:19:01 2005
Return-path: <katie@spohr.debian.org>
Received: from katie by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1EDhoW-0003Cn-00; Fri, 09 Sep 2005 05:17:04 -0700
From: Matej Vela <vela@debian.org>
To: 327303-close@bugs.debian.org
X-Katie: $Revision: 1.56 $
Subject: Bug#327303: fixed in libgtk-perl 0.7009-5
Message-Id: <E1EDhoW-0003Cn-00@spohr.debian.org>
Sender: Archive Administrator <katie@spohr.debian.org>
Date: Fri, 09 Sep 2005 05:17:04 -0700
Delivered-To: 327303-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: libgtk-perl
Source-Version: 0.7009-5

We believe that the bug you reported is fixed in the latest version of
libgtk-perl, which is due to be installed in the Debian FTP archive:

libgladexml-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgladexml-perl_0.7009-5_i386.deb
libgnome-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgnome-perl_0.7009-5_i386.deb
libgnome-print-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgnome-print-perl_0.7009-5_i386.deb
libgtk-imlib-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgtk-imlib-perl_0.7009-5_i386.deb
libgtk-perl_0.7009-5.diff.gz
  to pool/main/libg/libgtk-perl/libgtk-perl_0.7009-5.diff.gz
libgtk-perl_0.7009-5.dsc
  to pool/main/libg/libgtk-perl/libgtk-perl_0.7009-5.dsc
libgtk-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgtk-perl_0.7009-5_i386.deb
libgtk-pixbuf-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgtk-pixbuf-perl_0.7009-5_i386.deb
libgtkglarea-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgtkglarea-perl_0.7009-5_i386.deb
libgtkxmhtml-perl_0.7009-5_i386.deb
  to pool/main/libg/libgtk-perl/libgtkxmhtml-perl_0.7009-5_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 327303@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Matej Vela <vela@debian.org> (supplier of updated libgtk-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri,  9 Sep 2005 13:58:41 +0200
Source: libgtk-perl
Binary: libgnome-perl libgtk-pixbuf-perl libgtk-imlib-perl libgladexml-perl libgtk-perl libgnome-print-perl libgtkglarea-perl libgtkxmhtml-perl
Architecture: source i386
Version: 0.7009-5
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
Description: 
 libgladexml-perl - Perl module for the libglade library
 libgnome-perl - Perl module for the gnome and zvt libraries
 libgnome-print-perl - Perl module for the gnome print library
 libgtk-imlib-perl - Perl module for the gdkimlib library
 libgtk-perl - Perl module for the gtk+ library
 libgtk-pixbuf-perl - Perl module for the gdkpixbuf library
 libgtkglarea-perl - Perl module for the gtkglarea library
 libgtkxmhtml-perl - Perl module for the libgtkxmhtml library
Closes: 327303
Changes: 
 libgtk-perl (0.7009-5) unstable; urgency=low
 .
   * QA upload.
   * Replace build dependency on xlibmesa-dev with xlibmesa-gl-dev.
     Closes: #327303.
Files: 
 2caa9d672d099e469c64bc8eddf76fb5 994 perl optional libgtk-perl_0.7009-5.dsc
 fd8c50fe353af28a60be8abbfce5dd56 113114 perl optional libgtk-perl_0.7009-5.diff.gz
 026e9c8daa11d0b4d3717a6d2baf24ec 805112 perl optional libgtk-perl_0.7009-5_i386.deb
 798a0b15a206be533e02c6cc58234e62 58064 perl optional libgtk-imlib-perl_0.7009-5_i386.deb
 a547453789829deac7e29420d7705904 55654 perl optional libgtk-pixbuf-perl_0.7009-5_i386.deb
 47f9ac670583a1d9b0d74de8d08172f9 271336 perl optional libgnome-perl_0.7009-5_i386.deb
 248de089e682419e119d1b4359f14ff1 83208 perl optional libgnome-print-perl_0.7009-5_i386.deb
 045fbb4f8c32b64bb043bc7dca16c854 48470 perl optional libgtkglarea-perl_0.7009-5_i386.deb
 ee04f9f266ffde35ef9ce9e1335084df 48964 perl optional libgladexml-perl_0.7009-5_i386.deb
 e9d0f25202b088cc612c7767579f21c9 46710 perl optional libgtkxmhtml-perl_0.7009-5_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDIXnqxBYivKllgY8RAuF1AJ9KdIG/WgQ9lw7iNbUe4xgoAZIDpgCcCXIk
4X5dmMub6NvMMZBKnBgAGKM=
=fPCX
-----END PGP SIGNATURE-----



Reply to: