[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274980: marked as done (libplot: broken postscript)

Your message dated Fri, 06 May 2005 19:32:38 -0400
with message-id <E1DUCJC-0006WH-00@newraff.debian.org>
and subject line Bug#274980: fixed in plotutils 2.4.1-12
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 5 Oct 2004 06:55:42 +0000
>From jvkujala@tukki.cc.jyu.fi Mon Oct 04 23:55:42 2004
Return-path: <jvkujala@tukki.cc.jyu.fi>
Received: from posti6.jyu.fi [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CEjEb-0006aK-00; Mon, 04 Oct 2004 23:55:42 -0700
Received: from tukki.cc.jyu.fi (daemon@tukki.cc.jyu.fi [])
	by posti6.jyu.fi (8.12.8/8.12.8/antispam) with ESMTP id i956tdoa019545
	for <submit@bugs.debian.org>; Tue, 5 Oct 2004 09:55:39 +0300
Received: (from jvkujala@localhost)
	by tukki.cc.jyu.fi (8.11.7p1+Sun/8.10.2) id i956tdY15232
	for submit@bugs.debian.org; Tue, 5 Oct 2004 09:55:39 +0300 (EEST)
Date: Tue, 5 Oct 2004 09:55:39 +0300
From: "Janne V. Kujala" <jvkujala@cc.jyu.fi>
To: submit@bugs.debian.org
Subject: libplot: broken postscript
Message-ID: <20041005065538.GA14793@cc.jyu.fi>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.4.1i
X-Virus-Scanned: by amavisd-milter (http://www.amavis.org/)
	at posti6.jyu.fi; Tue, 05 Oct 2004 09:55:40 +0300
X-Spam-Checked: by miltrassassin
	at posti6.jyu.fi; Tue, 05 Oct 2004 09:55:40 +0300
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_01,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: libplot2
Version: 2.4.1-10

Upgrading gsfonts to 8.* seems to trigger a bug in libplot postscript 
output. For example, the command

	echo | graph -Tps | gv -

yields a /rangecheck postscript error. 

The same problem is observed with an idraw generated file in an 
unsolved gsfonts bug report (#242015). A description of the problem 
and a fix is described in


The same fix seems to work for libplot, too. The command

	echo | graph -Tps | sed -e 's:\[FontBBox\]:/FontBBox load:' | gv -

does work. I suggests that the above substitution is applied to the
libplot source.

Received: (at 274980-close) by bugs.debian.org; 6 May 2005 23:44:42 +0000
>From katie@ftp-master.debian.org Fri May 06 16:44:42 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DUCUr-0006kz-00; Fri, 06 May 2005 16:44:41 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1DUCJC-0006WH-00; Fri, 06 May 2005 19:32:38 -0400
From: Matej Vela <vela@debian.org>
To: 274980-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#274980: fixed in plotutils 2.4.1-12
Message-Id: <E1DUCJC-0006WH-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Fri, 06 May 2005 19:32:38 -0400
Delivered-To: 274980-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 3

Source: plotutils
Source-Version: 2.4.1-12

We believe that the bug you reported is fixed in the latest version of
plotutils, which is due to be installed in the Debian FTP archive:

  to pool/main/p/plotutils/libplot-dev_2.4.1-12_i386.deb
  to pool/main/p/plotutils/libplot2_2.4.1-12_i386.deb
  to pool/main/p/plotutils/plotutils_2.4.1-12.diff.gz
  to pool/main/p/plotutils/plotutils_2.4.1-12.dsc
  to pool/main/p/plotutils/plotutils_2.4.1-12_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 274980@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matej Vela <vela@debian.org> (supplier of updated plotutils package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat,  7 May 2005 01:03:07 +0200
Source: plotutils
Binary: libplot-dev plotutils libplot2
Architecture: source i386
Version: 2.4.1-12
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
 libplot-dev - The GNU plotutils libraries (development files)
 libplot2   - The GNU plotutils libraries
 plotutils  - The GNU plotutils (plotting utilities) package
Closes: 206507 271520 274980 294051
 plotutils (2.4.1-12) unstable; urgency=low
   * QA upload.
   * libplot/p_header.h: Replace `[FontBBox]' with `/FontBBox load'.
     Closes: #274980.
   * info/ode.1, info/plot.1, info/plotfont.1, info/tek2plot.1: Prevent .SB
     macro definition from showing up in whatis(1) output.  Closes: #206507.
   * info/plotutils.texi: Remove repeated directory entry.  Closes: #294051.
   * Replace `Build-Depends: xlibs-dev' with individual -dev packages.
     Closes: #271520.
   * Add watch file.
   * Conforms to Standards version 3.6.1.
 2c4c3040972fb431e9b6df9a852cff12 737 math optional plotutils_2.4.1-12.dsc
 33171fd07cbd6a2f2d74966b79811ffc 336512 math optional plotutils_2.4.1-12.diff.gz
 da305a56b8144d18745e02814f59245c 649798 math optional plotutils_2.4.1-12_i386.deb
 3539e940be98de244b2ada9e826dc428 873772 libs optional libplot2_2.4.1-12_i386.deb
 1c1dd0fee9a80c965f12540110f0b454 1077744 devel optional libplot-dev_2.4.1-12_i386.deb

Version: GnuPG v1.4.0 (GNU/Linux)


Reply to: