[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#307197: bbconf: Seg faults on start when no blackbox configuration exists

Package: bbconf
Version: 1.10-6.1
Severity: normal

  When I start blackbox with no existing configuration information (no
.blackboxrc, .blackbox/, .bbkeysrc, or .bbtools in ~), it immediately
seg faults:

[moise@mole ~]$ gdb bbconf
GNU gdb 6.3-debian
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-linux"...Using host libthread_db library

(gdb) run
Starting program: /usr/bin/bbconf 
[Thread debugging using libthread_db enabled]
[New Thread -1220317056 (LWP 5369)]
Could not open config file: Couldn't find style file.
Using internal defaults for plugin.
Could not open config file: /home/moise/.bbconf/config
Using internal defaults for plugin.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1220317056 (LWP 5369)]
MainWindow::widgetChanging (this=0xbffff6e0, w=0x8313240) at plugin.h:41
41              bool isModified() const { return m_modified; }
(gdb) bt
#0  MainWindow::widgetChanging (this=0xbffff6e0, w=0x8313240) at plugin.h:41
#1  0x080513e8 in MainWindow::changeFrame (this=0xbffff6e0, item=0x8313240)
    at tree.h:82
#2  0x08053f9c in MainWindow::qt_invoke (this=0xbffff6e0, _id=48, 
    _o=0xbffff530) at qucom_p.h:312
#3  0xb7b6771c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#4  0xb7eb873b in QListView::selectionChanged () from /usr/lib/libqt-mt.so.3
#5  0xb7c4fd1b in QListView::setSelected () from /usr/lib/libqt-mt.so.3
#6  0x08052043 in MainWindow::setPlugins (this=0xbffff6e0, plist=0x8186568, 
    start_plugin=@0xbffff840) at win.cc:222
#7  0x080533e0 in main (argc=1, argv=0xbffff8f4) at main.cc:195

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.10-1-686-smp
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages bbconf depends on:
ii  libaudio2            1.7-2               The Network Audio System (NAS). (s
ii  libc6                2.3.2.ds1-21        GNU C Library: Shared libraries an
ii  libfontconfig1       2.3.2-1             generic font configuration library
ii  libfreetype6         2.1.7-2.4           FreeType 2 font engine, shared lib
ii  libgcc1              1:3.4.3-12          GCC support library
ii  libice6              4.3.0.dfsg.1-12.0.1 Inter-Client Exchange library
ii  libpng12-0           1.2.8rel-1          PNG library - runtime
ii  libqt3c102-mt        3:3.3.4-3           Qt GUI Library (Threaded runtime v
ii  libsm6               4.3.0.dfsg.1-12.0.1 X Window System Session Management
ii  libstdc++5           1:3.3.5-12          The GNU Standard C++ Library v3
ii  libx11-6             4.3.0.dfsg.1-12.0.1 X Window System protocol client li
ii  libxcursor1          1.1.3-1             X cursor management library
ii  libxext6             4.3.0.dfsg.1-12.0.1 X Window System miscellaneous exte
ii  libxft2              2.1.7-1             FreeType-based font drawing librar
ii  libxrandr2           4.3.0.dfsg.1-12.0.1 X Window System Resize, Rotate and
ii  libxrender1          0.8.3-7             X Rendering Extension client libra
ii  libxt6               4.3.0.dfsg.1-12.0.1 X Toolkit Intrinsics
ii  xlibs                4.3.0.dfsg.1-12     X Keyboard Extension (XKB) configu
ii  zlib1g               1:1.2.2-4           compression library - runtime

-- no debconf information

Reply to: