[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#289464: cron-lib.pl probably exit()s somewhere

tags 289464 +woody


Investigating a customers support request I tracked the problem
down to foreign_require() on cron being broken (exits).

Following I paste my notes, in case they might be helpful (inverse
chronological order):

Date: 2005-01-12 16:43
Sender: arthur
Logged In: YES 

I tried to install a fresh current cron module (only the 
cron module) from webmin.com. This failed since KAPA has 
webmin 0.94 and webmin.com has 1.170 (which is in testing 
Then I fetched webmin-core from debian and untarred the 
cron module from there. Didn't work either (same error as 
we had in the first place). 
Further I noticed that the acl_security.pl form (shown in 
the "webmin users" module) is broken too. I couldn't
or get it to produce logs error messages. It seems to 
terminate before producing any output for all CGIs in 
webmin/cron/*. It can't be a die() or a compilation error, 
I tried this and they _allways_ lead to an error being 
sent to the user. 
Maybe they should try with a current Webmin first, since 
it works for me with the webmin from testing/unstable 

Date: 2005-01-12 15:41
Sender: arthur
Logged In: YES 

When I try to access the cron module in webmin on KAPA I 
get this: 
Beim Laden von https://localhost:11111/cron/ ist folgender 
Fehler aufgetreten: 
Verbindung zu Rechner localhost ist unterbrochen 
Which kinda explains the problem ... 

Date: 2004-12-24 13:42
Sender: arthur
Logged In: YES 

Hmm, fiddling around with my installation here it looks 
like it can't be the cron module entirely missing. Maybe 
it just fails or such. I need shell access on the affected 
machine to tell for shure. 
For the content-type header not to be printed, something 
in this code has to exit: 
require './afbackup-lib.pl'; # not specific to this script 
&foreign_require('cron', 'cron-lib.pl'); 
if ($in{'submit'}) { # only for saving 
my %job; # cant exit 
@job{qw(mins hours days months weekdays)} = split(/\s+/, 
$in{'custom'}); # cant exit 
&afheader('edit_schedule_custom'); # not specific 
So you see, the foreign_require is a strong candidate. 

Date: 2004-12-24 13:32
Sender: arthur
Logged In: YES 

Check whether the webmin cron module is available. 
This is actually a declared webmin dependency, but I never 
thought about checking what webmin does when such dep's 
are not satisfied after webmin upgrades and suchlike (only 
on module install). 

[It all started with a message from a customer complaining that he can't
modify his backup schedules when he want's to use the "custom" method
(which uses cron-lib.pl forms)]

ciao, 2ri
Secure email, spread GPG, clearsign all mail. http://www.gnupg.org
Following the First World War, Austrian journalist Karl Wiegand made 
an interesting observation. "How are nations ruled and led into war?" 
he asked. "Politicians lie to journalists and then believe those lies 
when they see them in print." This may seem cynical, but it was true 
then, and it is true today.

Attachment: signature.asc
Description: Digital signature

Reply to: