[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#185372: marked as done (python-bsddb3: Must depend on particular version of python, as per Python Policy.)

Your message dated 10 Aug 2004 22:30:11 -0700
with message-id <87brhickd8.fsf@becket.becket.net>
and subject line bugs done
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 19 Mar 2003 00:36:38 +0000
>From abo@minkirri.apana.org.au Tue Mar 18 18:36:38 2003
Return-path: <abo@minkirri.apana.org.au>
Received: from minkirri.apana.org.au [] (postfix)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 18vRZK-0003bS-00; Tue, 18 Mar 2003 18:36:37 -0600
Received: by minkirri.apana.org.au (Postfix, from userid 1000)
	id 1180A978CC; Wed, 19 Mar 2003 11:36:24 +1100 (EST)
From: Donovan Baarda <abo@minkirri.apana.org.au>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: python-bsddb3: Must depend on particular version of python, as per Python Policy.
X-Mailer: reportbug 1.50
Date: Wed, 19 Mar 2003 11:36:24 +1100
Message-Id: <20030319003624.1180A978CC@minkirri.apana.org.au>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-0.2 required=4.0

Package: python-bsddb3
Version: 3.3.0-5.1
Severity: serious
Justification: Python Policy

The "empty default" package that ensures that support is provided for the
default version of python must depend on the particular version of python it

Depends: python (>= X.Y), python (<< X.Y+1), pythonX.Y-foo

This ensures that the correct version of python-bsddb3 and corresponding
pythonX.Y-bsddb3 is installed together with the corresponding X.Y version of
the "default" python.

Without this, this package can be installed on a "testing" or "stable"
system where the default version of python is 2.1, not 2.2, resulting in no
python-bsddb3 support when running the default /usr/bin/python.

-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux minkirri 2.4.20-686 #1 Mon Jan 13 22:22:30 EST 2003 i686
Locale: LANG=en_AU, LC_CTYPE=en_AU

Versions of packages python-bsddb3 depends on:
ii  python2.2-bsddb3              3.3.0-5.1  Python 2.2 interface to libdb3

Versions of packages python-bsddb3 _should_ depend on:
ii  python                         2.1.3-4   An interactive object-oriented

Received: (at 185372-done) by bugs.debian.org; 11 Aug 2004 05:32:09 +0000
>From tb@becket.net Tue Aug 10 22:32:09 2004
Return-path: <tb@becket.net>
Received: from vp085189.reshsg.uci.edu (becket.becket.net) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Bulib-0007VA-00; Tue, 10 Aug 2004 22:32:09 -0700
Received: from tb by becket.becket.net with local (Exim 4.34)
	id 1Bulia-000784-Lp; Tue, 10 Aug 2004 22:32:08 -0700
To: 126490-done@bugs.debian.org, 165999-done@bugs.debian.org,
        185372-done@bugs.debian.org, 168447-done@bugs.debian.org,
Subject: bugs done
X-Reply-Permission: Posted or emailed replies to this message constitute
		 permission for an emailed response.
X-PGP-Fingerprint: 1F0A1E51  63 28 EB DA E6 44 E5 5E  EC F3 04 26 4E BF 1A 92
X-Tom-Swiftie: "I can't get this fire started," Tom said woodenly
From: Thomas Bushnell BSG <tb@becket.net>
Date: 10 Aug 2004 22:30:11 -0700
Message-ID: <87brhickd8.fsf@becket.becket.net>
Lines: 9
User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Delivered-To: 185372-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 
X-CrossAssassin-Score: 4

Bug 126490, 165999: fixed by maintainer in 3.3.0-2 and 3.3.0-5, but he
used a different email address so they were only marked closed,
instead of fixed.

Bug 185372, 168447, 204702: Fixed by NMU 3.3.0-5.1, 3.3.0-5.2, and
3.3.0-5.2, and became accepted when the package was taken by QA in
version 3.3.0-6.

Reply to: