[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247285: FTBFS on new X packages from sid

tags 247285 = confirmed

On Tue, May 04, 2004 at 06:14:55PM +0300, Aigars Mahinovs wrote:
> On Tue, 2004-05-04 at 17:01, Jeroen van Wolffelaar wrote:
> > severity 247285 serious
> > tags 247285 + unreproducable
> > thanks
> > 
> > > /usr/X11R6/include/X11/Xmu/WinUtil.h has mooved to libxmu-dev in new X
> > > packages from unstable. This package should be added to Build-Depends.
> > 
> > I unsuccesfully tried to verify this by de-installing libxmu-dev and
> > building it until well into compile (but killed it then). Note that this
> > package doesn't depend on X at all, so really don't understand.
> Sorry, the bug report should have been more verbose.
> I build gnome-panel in pbuilder, so only Build-Depends and
> build-essentials are installed. The problem occurs with the new X
> version 4.3.0.dfsg-1.1, where libxmu-dev headers are moved to libxmu-dev
> (from xlibs-dev IIRC). Here is the build failure:

> | -Wmissing-prototypes      -Wall -g -O2 -c gnome-panel-screenshot.c
> | gnome-panel-screenshot.c:51:29: X11/Xmu/WinUtil.h: No such file or
> | directory

Ah, I see.

> As we see, the gnome-panel-screenshot.c uses X11/Xmu/WinUtil.h, but it
> doesn't build-depend on it. On the other hand, it also might be a bug of
> libgnomeui-dev or libgnome-desktop-dev, that should have depended on
> this package.

gnome-panel should depend on all libraries it uses itself, and since the
code itself refers to a headerfile it doesn't build-depend on, it is a

It might have worked before because some build-dep used to depend on
xlibs-dev, but it still was a bug before that: you should not rely on
indirect build-dependencies pulled in, but only directly depend on
anything you need yourself.


Jeroen van Wolffelaar
Jeroen@wolffelaar.nl (also for Jabber & MSN; ICQ: 33944357)

Reply to: