[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241100: marked as done (please provide /usr/share/xsessions/gnome.desktop)

Your message dated Wed, 31 Mar 2004 09:32:04 -0500
with message-id <E1B8glA-00053p-00@newraff.debian.org>
and subject line Bug#241100: fixed in gnome-session 2.4.2-3
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 30 Mar 2004 08:10:29 +0000
>From mikal@stillhq.com Tue Mar 30 00:10:29 2004
Return-path: <mikal@stillhq.com>
Received: from cs.anu.edu.au [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B8EKK-0001eq-00; Tue, 30 Mar 2004 00:10:28 -0800
Received: from box.anu.edu.au ([] helo=[])
	by cs.anu.edu.au with esmtp (Exim 3.35 #1 (Debian))
	id 1B8EKD-0000Xp-00; Tue, 30 Mar 2004 18:10:21 +1000
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Michael Still <mikal@stillhq.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gdm: Gnome not available as a session type after upgrade
Bcc: Michael Still <mikal@stillhq.com>
X-Mailer: reportbug 2.55
Date: Tue, 30 Mar 2004 18:10:38 +1000
Message-Id: <E1B8EKD-0000Xp-00@cs.anu.edu.au>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.5 required=4.0 tests=BAYES_01,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: gdm
Severity: grave
Justification: renders package unusable

This morning I did a dist-upgrade on unstable, which updated gnome. I 
said to keep my existing config file when prompted to by apt-get. When I 
restarted my X session this afternoon, Gnome and KDE were no longer 
available as login session types, and only the failsafe options 

A dpkg-reconfigure results in the following error message:

Unknown error, message=replacewith($string, $replace, $with): $replace 
and $with must have the same length.
install-menu: /etc/menu-methods/freedesktop-desktop-entry-spec-dirs: 
update-menus[1705]: Script 
/etc/menu-methods/freedesktop-desktop-entry-spec-dirs returned error 
status 1.
Unknown error, message=replacewith($string, $replace, $with): $replace 
and $with must have the same length.
install-menu: /etc/menu-methods/freedesktop-desktop-entry-spec-apps: 
update-menus[1705]: Script 
/etc/menu-methods/freedesktop-desktop-entry-spec-apps returned error 
status 1.

Is there a trivial way to rectify this so I can once more enjoy the 
Gnomy goodless which is my laptop?


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.5-rc1
Locale: LANG=C, LC_CTYPE=en_US.UTF-8

Versions of packages gdm depends on:
ii  adduser              3.52                Add and remove users and groups
ii  debconf              1.4.19              Debian configuration management sy
ii  dpkg                 1.10.20             Package maintenance system for Deb
ii  gnome-session        2.4.2-2             The GNOME 2 Session Manager
ii  gnome-terminal [x-te 2.4.2-7             The GNOME 2 terminal emulator appl
ii  libart-2.0-2         2.3.16-3            Library of functions for 2D graphi
ii  libatk1.0-0          1.4.1-1             The ATK accessibility toolkit
ii  libbonobo2-0         2.4.3-1             Bonobo CORBA interfaces library
ii  libbonoboui2-0       2.4.3-2             The Bonobo UI library
ii  libc6                2.3.2.ds1-11        GNU C Library: Shared libraries an
ii  libgconf2-4           GNOME configuration database syste
ii  libglade2-0          2.0.1-11            Library to load .glade files at ru
ii  libglib2.0-0         2.2.3-1             The GLib library of C routines
ii  libgnome2-0          2.4.0-9             The GNOME 2 library - runtime file
ii  libgnomecanvas2-0    2.4.0-3             A powerful object-oriented display
ii  libgnomeui-0          The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0       2.4.1-5             The GNOME virtual file-system libr
ii  libgnomevfs2-common  2.4.1-5             The GNOME virtual file-system libr
ii  libgsf-1             1.8.2-6             Structured File Library - runtime 
ii  libgtk2.0-0          2.2.4-3             The GTK+ graphical user interface 
ii  libice6              4.3.0-7             Inter-Client Exchange library
ii  liborbit2            1:2.8.3-2           libraries for ORBit2 - a CORBA ORB
ii  libpam-modules       0.76-16             Pluggable Authentication Modules f
ii  libpam-runtime       0.76-16             Runtime support for the PAM librar
ii  libpam0g             0.76-16             Pluggable Authentication Modules l
ii  libpango1.0-0        1.2.5-2.1           Layout and rendering of internatio
ii  libpopt0             1.7-4               lib for parsing cmdline parameters
ii  librsvg2-2           2.5.0-2             SAX-based renderer library for SVG
ii  libsm6               4.3.0-7             X Window System Session Management
ii  libwrap0             7.6-ipv6.1-3        Wietse Venema's TCP wrappers libra
ii  libx11-6             4.3.0-7             X Window System protocol client li
ii  libxext6             4.3.0-7             X Window System miscellaneous exte
ii  libxml2              2.6.7-1             GNOME XML library
ii  metacity [x-window-m 1:2.6.5-1           A lightweight GTK2 based Window Ma
ii  sawfish [x-window-ma 1:1.3+cvs20031104-4 A window manager for X11
ii  twm [x-window-manage 4.3.0-7             Tab window manager
ii  xlibs                4.3.0-7             X Window System client libraries m
ii  xterm [x-terminal-em 4.3.0-7             X terminal emulator
ii  zlib1g               1:1.2.1-5           compression library - runtime

-- debconf information:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_CTYPE = "en_US.UTF-8",
	LANG = (unset)
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
  gdm/daemon_name: /usr/bin/gdm
* shared/default-x-display-manager: gdm

Received: (at 241100-close) by bugs.debian.org; 31 Mar 2004 14:38:02 +0000
>From katie@ftp-master.debian.org Wed Mar 31 06:38:02 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B8gqw-00064d-00; Wed, 31 Mar 2004 06:38:02 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1B8glA-00053p-00; Wed, 31 Mar 2004 09:32:04 -0500
From: Josselin Mouette <joss@debian.org>
To: 241100-close@bugs.debian.org
X-Katie: $Revision: 1.45 $
Subject: Bug#241100: fixed in gnome-session 2.4.2-3
Message-Id: <E1B8glA-00053p-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Wed, 31 Mar 2004 09:32:04 -0500
Delivered-To: 241100-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Source: gnome-session
Source-Version: 2.4.2-3

We believe that the bug you reported is fixed in the latest version of
gnome-session, which is due to be installed in the Debian FTP archive:

  to pool/main/g/gnome-session/gnome-session_2.4.2-3.diff.gz
  to pool/main/g/gnome-session/gnome-session_2.4.2-3.dsc
  to pool/main/g/gnome-session/gnome-session_2.4.2-3_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 241100@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Josselin Mouette <joss@debian.org> (supplier of updated gnome-session package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed, 31 Mar 2004 15:56:40 +0200
Source: gnome-session
Binary: gnome-session
Architecture: source i386
Version: 2.4.2-3
Distribution: unstable
Urgency: low
Maintainer: Josselin Mouette <joss@debian.org>
Changed-By: Josselin Mouette <joss@debian.org>
 gnome-session - The GNOME 2 Session Manager
Closes: 238885 241100
 gnome-session (2.4.2-3) unstable; urgency=low
   * Re-use work from Gustavo Noronha Silva <kov@debian.org> for 2.6.0:
    + debian/control.in:
     - set maintainer to Josselin Mouette <joss@debian.org>
       (closes: #238885).
     - Build-Depends on cdbs and gnome-pkg-tools
    + debian/patches/*:
     - converted all from dpatch to cdbs' simple-patch, some
       of them were regenerated for various reasons, including
       failure on apply and not including diff for Makefile.am
    + debian/rules:
     - use cdbs
    + gnome-session.install:
     - install some debian specific files that were installed
       manually through debian/rules before
   * Use metacity by default:
     + gnome-wm: use metacity or sawfish when it is available
     + default.session: let gnome-wm discover the window manager
   * docs: removed, cdbs takes care of these.
   * postinst,prerm: remove gconf stuff, dh_gconf does it for us.
   * control.in: require debhelper 4.1.84.
   * Provide a session for the display managers (closes: #241100):
     + add gnome-session.desktop
     + gnome-session.install: install it
   * patches/:
     + 01_configure.diff, 03_Makefile.in.diff: removed
     + 00_Makefile.am.diff patches gnome-session/Makefile.am
     + 00_acinclude.m4.diff includes a copy of gnome2-macros/compiler-flags.m4
       as aclocal 1.7 seems unable to find it.
     + 01_autoreconf.diff is the result of running libtoolize --force --copy;
       aclocal; autoheader; automake -acf; autoconf.
   * Use the splash screen from desktop-base by default.
     + patches/03_splash.diff: for the code and gconf stuff
     + control.in: depend on desktop-base.
   * control.in: don't depend on debianutils, woody provides a sufficient
   * fix permissions:
     + compat: use debhelper v4
     + rules: chmod 755 the debian scripts
 7fb4763ae0672c595bf1fbdd0f3a427b 1561 gnome optional gnome-session_2.4.2-3.dsc
 484ec1acdf48028e44a5630e60840f31 127822 gnome optional gnome-session_2.4.2-3.diff.gz
 e33da0f58c01bf523b878e5151d658b9 483458 gnome optional gnome-session_2.4.2-3_i386.deb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: