[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#169410: marked as done (pilot-link: Mess with Python version in source package)

Your message dated Fri, 20 Jun 2003 19:32:34 -0400
with message-id <E19TVMw-0002AG-00@auric.debian.org>
and subject line Bug#169410: fixed in pilot-link 0.11.7-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 17 Nov 2002 01:10:07 +0000
>From jwarnier@bxlug.be Sat Nov 16 19:10:06 2002
Return-path: <jwarnier@bxlug.be>
Received: from amsfep11-int.chello.nl [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 18DDws-0001mZ-00; Sat, 16 Nov 2002 19:10:06 -0600
Received: from aphrodite.bxlug.be ([])
          by amsfep11-int.chello.nl
          (InterMail vM. 201-253-122-118-106-20010523) with ESMTP
          id <20021117010935.ZXRA1218.amsfep11-int.chello.nl@aphrodite.bxlug.be>;
          Sun, 17 Nov 2002 02:09:35 +0100
Received: by aphrodite.bxlug.be (Postfix, from userid 1000)
	id 106A04F43A; Sun, 17 Nov 2002 02:09:35 +0100 (CET)
From: Jerome Warnier <jwarnier@bxlug.be>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: pilot-link: Mess with Python version in source package
X-Mailer: reportbug 1.50
Date: Sun, 17 Nov 2002 02:09:34 +0100
Message-Id: <20021117010935.106A04F43A@aphrodite.bxlug.be>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-3.6 required=5.0

Package: pilot-link
Version: 0.11.4-1.1
Severity: normal

As you may already know (bug #169408), I am worried about compiling
pilot-link on Woody (to get a backport of Evolution 1.2).

There is a big mess with the Python version, which I solved by changing
some dependencies in debian/control and replacing usr/lib/python2.2 by
usr/lib/python2.1 in debian/python-pisock.files.
A cleaner solution should be possible, though.
Here you have a diff:
< Build-Depends: debhelper (>= 3.0.18), perl (>= 5.8.0-3), python-dev
(>= 2.2), python-dev (<< 2.3), libpng3-dev, libreadline4-dev
> Build-Depends: debhelper (>= 3.0.18), perl, python2.2-dev, python-dev
> (<< 2.3), libpng-dev, libreadline4-dev
< Depends: ${shlibs:Depends}, python (>= 2.2), python (<< 2.3)
> Depends: ${shlibs:Depends}, python2.2, python (<< 2.3)

I think python2.2 and python2.2-dev should be respectively replaceable by python and python-dev.
My concern is about the file "debian/python-pisock.files" and the
hardcoded "usr/lib/python2.2" in it.
Maybe using dh_install instead of dh_movefiles could resolve this?

Also, in debian/rules, you will find an (unuseful) explicit use of "python2.1" in a "rm"!

I honestly don't know about "libpng-dev" in Sid, so you may ignore this

PS: I've got Evolution 1.2 running on my Woody now!
PS1: don't hesitate to ask for more details or help.

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux aphrodite.bxlug.be 2.4.18-686 #1 Sun Apr 14 11:32:47 EST 2002 i686

Versions of packages pilot-link depends on:
ii  debconf                 1.0.32           Debian configuration management sy
ii  libc6                   2.2.5-11.2       GNU C Library: Shared libraries an
ii  libpisock++0            0.11.4-1.1       C++ libraries for communicating wi
ii  libpisock8              0.11.4-1.1       Libraries for communicating with a
ii  libpng2                 1.0.12-3.woody.2 PNG library - runtime
ii  libreadline4            4.2a-5           GNU readline and history libraries
ii  libstdc++2.10-glibc2.2  1:2.95.4-7       The GNU stdc++ library

Received: (at 169410-close) by bugs.debian.org; 20 Jun 2003 23:39:32 +0000
>From katie@auric.debian.org Fri Jun 20 18:39:31 2003
Return-path: <katie@auric.debian.org>
Received: from auric.debian.org [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 19TVTf-0004yP-00; Fri, 20 Jun 2003 18:39:31 -0500
Received: from katie by auric.debian.org with local (Exim 3.35 1 (Debian))
	id 19TVMw-0002AG-00; Fri, 20 Jun 2003 19:32:34 -0400
From: Ludovic Rousseau <rousseau@debian.org>
To: 169410-close@bugs.debian.org
X-Katie: $Revision: 1.34 $
Subject: Bug#169410: fixed in pilot-link 0.11.7-4
Message-Id: <E19TVMw-0002AG-00@auric.debian.org>
Sender: Archive Administrator <katie@auric.debian.org>
Date: Fri, 20 Jun 2003 19:32:34 -0400
Delivered-To: 169410-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
pilot-link, which is due to be installed in the Debian FTP archive:

  to pool/main/p/pilot-link/libpda-pilot-perl_0.11.7-4_i386.deb
  to pool/main/p/pilot-link/libpisock++0_0.11.7-4_i386.deb
  to pool/main/p/pilot-link/libpisock-dev_0.11.7-4_i386.deb
  to pool/main/p/pilot-link/libpisock8_0.11.7-4_i386.deb
  to pool/main/p/pilot-link/libpisync0_0.11.7-4_i386.deb
  to pool/main/p/pilot-link/pilot-link_0.11.7-4.diff.gz
  to pool/main/p/pilot-link/pilot-link_0.11.7-4.dsc
  to pool/main/p/pilot-link/pilot-link_0.11.7-4_i386.deb
  to pool/main/p/pilot-link/python-pisock_0.11.7-4_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 169410@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Ludovic Rousseau <rousseau@debian.org> (supplier of updated pilot-link package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 21 Jun 2003 00:04:20 +0200
Source: pilot-link
Binary: libpda-pilot-perl libpisock8 pilot-link libpisock++0 libpisync0 python-pisock libpisock-dev
Architecture: source i386
Version: 0.11.7-4
Distribution: unstable
Urgency: low
Maintainer: Ludovic Rousseau <rousseau@debian.org>
Changed-By: Ludovic Rousseau <rousseau@debian.org>
 libpda-pilot-perl - Perl tools to communicate with a PalmOS PDA over a serial port
 libpisock++0 - C++ libraries for communicating with a PalmOS PDA
 libpisock-dev - Development files for communicating with a PalmOS PDA
 libpisock8 - Libraries for communicating with a PalmOS PDA
 libpisync0 - Synchronization library for PalmOS devices
 pilot-link - Tools to communicate with a PalmOS PDA over a serial port
 python-pisock - Python tools to communicate with PalmOS PDA over a serial port
Closes: 160885 169410 176296 179963 182150 185812 195370
 pilot-link (0.11.7-4) unstable; urgency=low
   * New Maintainer. Many thanks to Ben Darnell for his work. Closes: #195370
   * debian/control:
    - Build-Depends: on libpng-dev instead of libpng3-dev,
    - Build-Depends: on libreadline-dev | libreadline4-dev instead of
    - pilot-link conflicts with pilot-link-perl. Closes: #179963
    - Standards-Version: 3.2.1 -> 3.5.10
   * debian/rules:
    - support debug and nostrip in $DEB_BUILD_OPTIONS
   * remove Debian added pilot-mail manpage since the binary do not exist
     anymore. Closes: #185812
   * pilot-datebook-joblist.c: use int instead of char for the switch variable.
     Correct a potential i386 bug and a real arm, powerpc and s390 bug.
     Closes: #182150, #160885
   * debian/python-pisock.files: do not hardcode the python version (2.2 in the
     present case) but use a jocker. Closes: #169410
   * pilot-link debconf: split in pilot-link.config and pilot-link.postinst
   * use debian-po to manage debconf questions translations
   * src/ietf2datebook.PL: use perl in #!. Closes: #176296
 26487a4b60f35ff7486311234dda435a 788 otherosfs optional pilot-link_0.11.7-4.dsc
 70b3bc6baf48b7d50f9aae5e4b633285 15181 otherosfs optional pilot-link_0.11.7-4.diff.gz
 8b224da568e9be832146c6ec47c15faa 61874 libs optional libpisock8_0.11.7-4_i386.deb
 297d6c4a2a78e68cb13154707775dddb 18016 libs optional libpisock++0_0.11.7-4_i386.deb
 cdfbd3153717ca096957d9c8e590c45c 105122 devel extra libpisock-dev_0.11.7-4_i386.deb
 a549475ed337d4e9fd3acfeeddbae33c 103886 devel extra libpda-pilot-perl_0.11.7-4_i386.deb
 e9b700c990225c61a6fd1fecf7da6c4f 28336 devel extra python-pisock_0.11.7-4_i386.deb
 85f214705fcd9c6eeda33bfe8e82ba18 307096 otherosfs optional pilot-link_0.11.7-4_i386.deb
 b6002938613712c5592e22795321e127 11068 libs optional libpisync0_0.11.7-4_i386.deb

Version: GnuPG v1.2.2 (GNU/Linux)


Reply to: