[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#160133: svgalib-bin: svgalib seg faults in __svgalib_InitializeAcceleratorInterface()

Package: svgalib-bin
Version: 1:1.4.3-7
Severity: important

svgalib-bin seg faults failing to run all the applications I have tried
on two different machines (Compaq Deskpro XE 560 and Toshiba Satellite
11CS), but correctly works on another (which has an accelerated GFX

GDB session looks like:

hutch:/mnt/microwin-cvs/src# gdb bin/mine
GNU gdb 2002-04-01-cvs
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
This GDB was configured as "i386-linux"...(no debugging symbols
(gdb) run
Starting program: /mnt/microwin-cvs/src/bin/mine
(no debugging symbols found)...(no debugging symbols found)...
[svgalib: allocated virtual console #8]
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x4002a855 in __svgalib_InitializeAcceleratorInterface ()
   from /usr/lib/libvga.so.1

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux hutch 2.4.19 #10 Sat Sep 7 17:26:59 BST 2002 i586

Versions of packages svgalib-bin depends on:
ii  libc6                         2.2.5-11.1 GNU C Library: Shared libraries an
ii  svgalibg1                     1:1.4.3-7  Console SVGA display utilities

Reply to: