[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Package icqlib does not build with automake 1.6


I am contacting you again because I sent some bad information
in my last message.

I had suggested that the minimal fix for a package that will only
build using automake 1.4 is to add version information to the
build-depends line, changing it to "automake (<< 1.5)".  

However, this doesn't work!  I had forgotten that automake has an
epoch on the version.  Thanks to Aurelien Jarno for pointing that out.

There is a better way to force automake 1.4, though, which Dennis
Schoen pointed out: change the build-depend to "automake1.4".

Sorry to all, especially if you just uploaded a revision with
a bogus build-dep.  ;-(

Also, I should emphasize that changing the build-dep is the minimal
fix.  You could, of course, update the package so that it works with
current automake.  Or better (IMHO): run automake in the source tree
before building the package, and don't build-depend on it.


To UNSUBSCRIBE, email to debian-qa-packages-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: