[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libhoard_2.1.0-1_i386.changes is NEW

  to pool/main/libh/libhoard/libhoard_2.1.0-1.diff.gz
  to pool/main/libh/libhoard/libhoard_2.1.0-1.dsc
(new) libhoard_2.1.0-1_i386.deb optional libs
fast memory allocation library
 The Hoard memory allocator is a fast, scalable, and memory-efficient
 memory allocator for shared-memory multiprocessors.
 More information can be found at the libhoard web site
  to pool/main/libh/libhoard/libhoard_2.1.0.orig.tar.gz
Changes: libhoard (2.1.0-1) unstable; urgency=low
  * QA upload.
  * New upstream version:
    * Since the library is no longer versioned, a single libhoard package
      supersedes libhoard1 and libhoard-dev.
    * Upstream doesn't distribute binaries of benchmarks, so I've left
      them out as well.  (Comments?)
  * Package is orphaned; maintainer set to Debian QA Group.
  * arch-specific.h: Checking for USER_LOCKS alone is enough since
    arch-specific.cpp already barfs on unsupported architectures.  (And
    ppc wasn't listed!)
  * Switched to debhelper 3.
  * debian/copyright: Added exception to LGPL.
  * debian/rules:
    * glibc wants -D_XOPEN_SOURCE=500 for pthread_setconcurrency and
      -D_BSD_SOURCE or -D_SVID_SOURCE for mremap.  Give it -D_GNU_SOURCE
      just to be sure.
    * Support DEB_BUILD_OPTIONS.
Announcing to debian-devel-changes@lists.debian.org
Closing bugs: 

Your package contains new components which requires manual editing of
the override file.  It is ok otherwise, so please be patient.  New
packages are usually added to the override file about once a week.

You may have gotten the distribution wrong.  You'll get warnings above
if files already exist in other distributions.

Reply to: