Post-install compilation of packages for unsupported Python versions (was: Packages that pretend to support Python 2.4)
Stefano Rivera <firstname.lastname@example.org> writes:
> Hi Jakub (2010.05.17_20:01:25_+0200)
> > 19 packages uses syntax constructs specific to Python 2.5+ in their
> > public modules but don't declare that minimum supported version is
> > 2.5. I'm looking for volunteers to do MBF.
> Done, only 13 real bugs.
Thanks for filing those, Stefano.
> All the bugs were just errors thrown in the python-support hook,
I admit to being surprised that it was attempting to compile for Python
2.4 when that version isn't supported any longer.
Do we consider it a bug that ‘python-support’ is attempting to compile
for Python versions we don't support? Should it constrain itself only to
those Python versions supported?
That leads, though, to the question of what to do about systems which
upgrade to Squeeze but still have Python 2.4 installed.
\ “Often, the surest way to convey misinformation is to tell the |
`\ strict truth.” —Mark Twain, _Following the Equator_ |