[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Python 2.6 transition update

Dear Debian Python,

As you may be aware, I have been making quite a bit of hue and cry
about the Python 2.6 transition blocking bugs[1]. I have managed to
submit patches for most of the packages to _make them build_ with
Python 2.6. However, as Paul Wise righly points out[2], my patches
merely make the packages build; I haven't really tested any of these
packages with Python 2.6 (In fact, I observe that fonttools is
dependent on python-numpy, which is not yet built with python 2.6, so
I shouldn't have sent that patch at all!). So, in my opinion, it would
be best if the maintainer, or someone who can invest time into
verifying that these packages do work with Python 2.6, performs
uploads to fix the blocking bugs.



[1]: http://bugs.debian.org/cgi-bin/pkgreport.cgi?users=debian-python@lists.debian.org;tag=python2.6
[2]: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=547821#20
Kumar Appaiah

Reply to: