[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

the python editor 'spe' package needs an update.

Hi there!

I subscribed to this list, cause my friend Martin 'Joey' Schulze adviced
me to do so and tell you about the matter I spotted...

The problem is not really a debian problem, cause the packages work well
and no dependencies are broken - but the actual Ubuntu Gutsy release
just claims Debian unstable (or etch?) to be  used for their needs -
which is _not_ a good idea:
their repository dependencies delivers python-wxgtk2.8 with it, which
does not work with the package spe in version 0.8.2a+repack-1 at all ;-)

I first solved the problem by editing this startupscript:
$editor /usr/share/pycentral/spe/site-packages/_spe/SPE.py
and replace by:
which is given as a dependency (by _your_ maintainer I'd suppose):
Depends: python, python-central (>= 0.5.6ubuntu2), *python-wxgtk2.6*,
python-wxglade, kiki
Thanks, for anybody who wrote this hint in here  ;-)

This solution is not really state of the art, so I checked out the svn
version here:
svn checkout svn://svn.berlios.de/python/spe/trunk/_spe
tested it running: python SPE.py
and it runs well, using the wxgtk2.8...

You may have a look at the complete repository here:

Joey said it is strongly adviced to upgrade the package, but it's
actally orphaned and nobody seems to feel responsible for.

Please keep in mind, that the debian-packages are not shipped with
broken packages - but you debians always fix such things faster than the
Ubuntus - I bet they just pick the new packages out the etch or unstable
repository, which seem to be the same for me.
Maybe you'll update to python-wxgtk2.8 and create a new package for spe
out of the svn as well to show the ubuntu-guys how those
package-update-things should be done perfecly...

Kind regards from Germany, I appreciate your work very much!


Reply to: