[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DEP-5 meta: New co-driver; current issues

On 2010-08-12, Lars Wirzenius <liw@liw.fi> wrote:
> * Various things are easier if debian/copyright can be parsed and
>   interpreted by software, rather than being free-form text. For
>   example, answering questions like "what stuff is GPLv2 only,
>   and therefore incompatible with GPLv3?".

This is quite useless as long as we are making copyright files for

source foo produces a library and some tools
the files ending up in the library is lgplv2+
the files ending up in the tools (executables) are gplv2only

and then a different gplv3+ app also uses libfoo. should this then be
marked as a "problem" ?


Reply to: