[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dropping sparc32 for Lenny (was: Scheduling linux-2.6 2.6.21-[23])



(Resending as I forgot to change the subject. Sorry about that.)

On Friday 18 May 2007 12:18, Bastian Blank wrote:
> I'd like to schedule the linux-2.6 2.6.21-[23] upload for today.
>
> Fixes:
[...]
> - sparc32 deprecation? No fix yet for the cmpxchg problem.

This would have a serious implication for Debian Installer as we'd also 
have to drop support for sparc32 if this is done.

The deprecation of sparc32 has been raised last month on the debian-sparc 
list [1] by Jurij Smakov with as main reason that there is basically no 
longer any upstream (kernel) support for sparc32. Other reasons were 
listed as well.
In that thread there was some opposition to the idea, but I've not seen 
anybody making the commitment to maintain sparc32, so dropping it for 
Lenny does seem logical.

However, I do not think this is a decision that should be made solely on 
the debian-kernel list. I also feel that the decision (when it has been 
made) should be announced to our users.

Cheers,
FJP

[1] http://lists.debian.org/debian-sparc/2007/04/msg00044.html
    This mail also lists the arguments for dropping sparc32.

Attachment: pgpNKbLwCuoI5.pgp
Description: PGP signature


Reply to: