[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#155998: Please close when appropriate

tag 155998 - woody
reassign 155998 project,dak

Helge Kreutzmann <kreutzm@itp.uni-hannover.de> writes:

> Hello,
> there will be no more point release for woody and this bug is not
> security-related. You have not even replied to this bug. So I think it
> can be closed, correct?
> Greetings
>             Helge

This bug is still very much relevant. It affects woody (old-stable),
sarge (stable), etch (testing) and even sid (unstable).

The problem is that architecture independent packages are blindly
included on all architectures.

The example in the bug is:

foobar-data (all) depends foobar (any), foobar is not available for
this architecture.

I believe uninstallable architecture independent packages can and
should be filtered out in main for each architecture for all
releases (or from testing down maybe as part of britney).


PS: Reassigning this also to dak as that is to blame.

Reply to: