[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#983349: hplip: while scanning , error 9 : impossible to scan



Package: hplip
Version: 3.21.2+dfsg1-1
Followup-For: Bug #983349
X-Debbugs-Cc: compte.perso.de-alain@bbox.fr

sorry , i have just seen : not unstable compatible .

so , if you think there's a solution , it will be good .

also , i am looking for a canon lide 25 scanner in order to solve the problem .

was searching a canonscan lide 300 but lide 25 was cheapiest .

shipped in germany .



-- Package-specific info:
Saving output in log file: /home/alain/hp-check.log

HP Linux Imaging and Printing System (ver. 3.21.2)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                    
2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                      
3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                    
a. EXTERNALDEP - External Dependencies                                          
b. GENERALDEP - General Dependencies (required both at compile and run time)    
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                    
PYEXT SCANCONF QUEUES PERMISSION                                                

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

Gtk-Message: 19:31:40.843: Failed to load module "canberra-gtk-module"
warning: debian-unstable version is not supported. Using debian-10.7 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.10.0-3-amd64 #1 SMP Debian 5.10.13-1 (2021-02-06) GNU/Linux
 Host: sid
 Proc: 5.10.0-3-amd64 #1 SMP Debian 5.10.13-1 (2021-02-06) GNU/Linux
 Distribution: debian unstable
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.21.2
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for debian distro  unstable version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.21.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.21.2
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[fax]
email_address = 
voice_phone = 

[last_used]
device_uri = escl:http://127.0.0.1:60000
printer_name = HP_ENVY_5530_series
working_dir = .

[polling]
device_list = 
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1613842662
notify_upgrade = true
pending_upgrade_time = 0

[installation]
date_time = 02/22/21 19:31:41
version = 3.21.2


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.53.3          OK         -
Gtk-Message: 19:31:42.385: Failed to load module "canberra-gtk-module"
Gtk-Message: 19:31:42.408: Failed to load module "canberra-gtk-module"
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.31          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.20         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.21            OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.8             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               -               OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 libavahi-dev         libavahi-dev                                                 REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.9             OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.9.1           OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.10          OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.9.1           OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               8.1.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.59          OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               10.2.1          OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.3             OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.21.2          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.21.2          OK         -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.21.2          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.21.2          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `escl:http://127.0.0.1:60000' is a HP ENVY 5530 series [FE04D6] (USB) flatbed scanner
device `hpaio:/usb/ENVY_5530_series?serial=CN595530XD06BX' is a Hewlett-Packard ENVY_5530_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                        Model              
  --------------------------------  -------------------
  hp:/usb/ENVY_5530_series?serial=  HP ENVY 5530 series
  CN595530XD06BX                                       

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


HP-ENVY-5530-series
-------------------
Type: Printer
Device URI: hp:/usb/ENVY_5530_series?serial=CN595530XD06BX
PPD: /etc/cups/ppd/HP-ENVY-5530-series.ppd
PPD Description: HP Envy 5530 Series, hpcups 3.21.2
Printer status: printer HP-ENVY-5530-series is idle.  enabled since Mon Feb 22 10:23:22 2021
error: Device busy: hp:/usb/ENVY_5530_series?serial=CN595530XD06BX
error: Device not found
error: Communication status: Failed

HP_ENVY_5530_series_FE04D6_USB_
-------------------------------
Type: Unknown
Device URI: implicitclass://HP_ENVY_5530_series_FE04D6_USB_/
PPD: /etc/cups/ppd/HP_ENVY_5530_series_FE04D6_USB_.ppd
PPD Description: HP ENVY 5530 series, driverless, cups-filters 1.28.7
Printer status: printer HP_ENVY_5530_series_FE04D6_USB_ is idle.  enabled since Mon Feb 22 18:41:00 2021
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

USB             HP-ENVY-5530-series            Required        -        -        OK       Node:'/dev/bus/usb/005/002' Perm:'  root  lp rw- rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'cups' package is missing or 'cups' service is not running.
error: 'libcups2' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'gtk2-engines-pixbuf' package is missing/incompatible 

Missing Optional Dependencies
-----------------------------
error: 'python3-dbus.mainloop.qt' package is missing/incompatible 

Total Errors: 4
Total Warnings: 1


Done.

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (100, 'testing'), (100, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.10.0-3-amd64 (SMP w/16 CPU threads)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages hplip depends on:
ii  adduser                3.118
ii  cups                   2.3.3op2-3
ii  hplip-data             3.21.2+dfsg1-1
ii  libc6                  2.31-9
ii  libcups2               2.3.3op2-3
ii  libdbus-1-3            1.12.20-2
ii  libhpmud0              3.21.2+dfsg1-1
ii  libpython3.9           3.9.1-4
ii  libsane-hpaio          3.21.2+dfsg1-1
ii  libsane1               1.0.31-4
ii  lsb-base               11.1.0
ii  printer-driver-hpcups  3.21.2+dfsg1-1
ii  python3                3.9.1-1
ii  python3-dbus           1.2.16-5
ii  python3-gi             3.38.0-2
ii  python3-pexpect        4.8.0-1
ii  python3-pil            8.1.0-1
ii  python3-reportlab      3.5.59-1
ii  wget                   1.21-1+b1
ii  xz-utils               5.2.5-1.0

Versions of packages hplip recommends:
ii  avahi-daemon                  0.8-5
ii  policykit-1                   0.105-30
ii  printer-driver-postscript-hp  3.21.2+dfsg1-1
ii  sane-utils                    1.0.31-4

Versions of packages hplip suggests:
pn  hplip-doc              <none>
ii  hplip-gui              3.21.2+dfsg1-1
ii  python3-notify2        0.3-4
ii  system-config-printer  1.5.14-1

-- no debconf information


Reply to: