[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#931818: marked as done (cups: Jobs webpage /usr/lib/cups/cgi-bin/jobs.cgi segfault after package login removes /etc/securetty)



Your message dated Mon, 28 Oct 2019 17:17:47 +0000
with message-id <28102019171546.cea2bddc379e@desktop.copernicus.org.uk>
and subject line Re: Bug#931818: Please close this bug
has caused the Debian Bug report #931818,
regarding cups: Jobs webpage /usr/lib/cups/cgi-bin/jobs.cgi segfault after package login removes /etc/securetty
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
931818: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931818
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cups
Version: 2.2.10-6
Severity: normal

Dear Maintainer,

Before the upgrade of login to 1:4.7-1 the "Jobs" webpage at
http://localhost:631/jobs/ worked as expected.  Since the upgrade I see the
following in the kernel log and jobs details fails with only the ID showing, no details and no way to act on that job.

Jul 10 14:30:55 systemname cupsd[13174]: pam_unix(cups:auth): Couldn't open /etc/securetty: No such file or directory
Jul 10 14:30:55 systemname cupsd[13174]: pam_unix(cups:auth): Couldn't open /etc/securetty: No such file or directory
Jul 10 14:30:55 systemname kernel: jobs.cgi[14724]: segfault at 0 ip 00007f1d61a91181 sp 00007ffdd76fa908 error 4 in libc-2.28.so[7f1d61957000+148000]
Jul 10 14:30:55 systemname kernel: Code: 84 00 00 00 00 00 0f 1f 00 31 c0 c5 f8 77 c3 66 2e 0f 1f 84 00 00 00 00 00 89 f9 48 89 fa c5 f9 ef c0 83 e1 3f 83 f9 20 77 1f <c5> fd 74 0f c5 fd d7 c1 85 c0 0f 85 df 00 00 00 48 83 c7 20 

I can confirm that /etc/securetty is no longer on my system.  I took a look at /usr/share/doc/login/changelog.Debian.gz:
  [ Balint Reczey ]
...
  * Clean up /etc/securetty properly on upgrade

I suspect this is the cause, but still.  I don't believe the segfault is the right behavior either.


-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cups depends on:
ii  cups-client            2.2.10-6
ii  cups-common            2.2.10-6
ii  cups-core-drivers      2.2.10-6
ii  cups-daemon            2.2.10-6
ii  cups-filters           1.21.6-5
ii  cups-ppdc              2.2.10-6
ii  cups-server-common     2.2.10-6
ii  debconf [debconf-2.0]  1.5.72
ii  ghostscript            9.27~dfsg-2
ii  libavahi-client3       0.7-4+b1
ii  libavahi-common3       0.7-4+b1
ii  libc6                  2.28-10
ii  libcups2               2.2.10-6
ii  libcupsimage2          2.2.10-6
ii  libgcc1                1:9.1.0-8
ii  libstdc++6             9.1.0-8
ii  libusb-1.0-0           2:1.0.22-2
ii  poppler-utils          0.71.0-5
ii  procps                 2:3.3.15-2

Versions of packages cups recommends:
ii  avahi-daemon                     0.7-4+b1
ii  colord                           1.4.3-4
ii  cups-filters [ghostscript-cups]  1.21.6-5
ii  printer-driver-gutenprint        5.3.1-7

Versions of packages cups suggests:
ii  cups-bsd               2.2.10-6
pn  cups-pdf               <none>
ii  foomatic-db            20181217-2
pn  hplip                  <none>
ii  printer-driver-hpcups  3.18.12+dfsg0-2
ii  smbclient              2:4.9.11+dfsg-1
ii  udev                   241-6

-- debconf information:
  cupsys/backend: lpd, socket, usb, snmp, dnssd
  cupsys/raw-print: true

--- End Message ---
--- Begin Message ---
On Mon 28 Oct 2019 at 09:48:12 -0500, Jeffrey E. Hundstad wrote:

> Hello,
> 
> Please close this bug.  I don't see anyone else that's having the same
> issue.  I now have a working cups installation myself.
> 
> I removed all the cups packages and associated unique support packages. 
> I then followed:
> https://wiki.debian.org/SystemPrinting
> 
> This instructed me to:
> apt install task-print-server
> 
> This solved my problem and printing is working fine.
> 
> Sorry for the noise.

Closing as requested. Thank you for getting back to us, Jeffrey.

Regards,

Brian.

--- End Message ---

Reply to: