[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#908305: ghostscript: CVE-2018-16585

Source: ghostscript
Version: 9.20~dfsg-3.2
Severity: grave
Tags: patch security upstream
Justification: user security hole
Forwarded: https://bugs.ghostscript.com/show_bug.cgi?id=699663
Control: fixed -1 9.20~dfsg-3.2+deb9u3


The following vulnerability was published for ghostscript.

| An issue was discovered in Artifex Ghostscript before 9.24. The
| .setdistillerkeys PostScript command is accepted even though it is not
| intended for use during document processing (e.g., after the startup
| phase). This leads to memory corruption, allowing remote attackers able
| to supply crafted PostScript to crash the interpreter or possibly have
| unspecified other impact.

If you fix the vulnerability please also make sure to include the
CVE (Common Vulnerabilities & Exposures) id in your changelog entry.

For further information see:

[0] https://security-tracker.debian.org/tracker/CVE-2018-16585
[1] http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=1497d65039885a52b598b137dd8622bd4672f9be
[2] http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=971472c83a345a16dac9f90f91258bb22dd77f22
[3] https://bugs.ghostscript.com/show_bug.cgi?id=699663

Please adjust the affected versions in the BTS as needed.


Reply to: