[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#706888: cups: Could not print to server after upgrade: Failed to add Avahi entry



Package: cups
Version: 1.5.3-5
Severity: important
Tags: patch

Dear Maintainer,

After a normal upgrade of Wheezy I could not print anymore from a
CUPS client to the CUPS server. On the server I found below
entry in /var/log/cups/error_log

E [05/May/2013:08:28:43 +0200] Failed to add Avahi entry for HP LaserJet 1320 @ emael: -8
E [05/May/2013:08:28:43 +0200] Failed to update TXT record for HP LaserJet 1320 @ emael: -2
E [05/May/2013:08:28:43 +0200] Failed to add Avahi entry for HP LaserJet 1320 @ emael: -8

What I did to fix it? 

Install avahi-discover on the client and run it as normal user.

This fixes the problem.



-- System Information:
Debian Release: 7.0
  APT prefers testing
  APT policy: (900, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=nl_NL.UTF-8, LC_CTYPE=nl_NL.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cups depends on:
ii  adduser                3.113+nmu3
ii  bc                     1.06.95-2+b1
ii  cups-client            1.5.3-5
ii  cups-common            1.5.3-5
ii  cups-filters           1.0.18-2.1
ii  cups-ppdc              1.5.3-5
ii  debconf [debconf-2.0]  1.5.49
ii  dpkg                   1.16.10
ii  ghostscript            9.05~dfsg-6.3
ii  libavahi-client3       0.6.31-2
ii  libavahi-common3       0.6.31-2
ii  libc-bin               2.13-38
ii  libc6                  2.13-38
ii  libcups2               1.5.3-5
ii  libcupscgi1            1.5.3-5
ii  libcupsimage2          1.5.3-5
ii  libcupsmime1           1.5.3-5
ii  libcupsppdc1           1.5.3-5
ii  libdbus-1-3            1.6.8-1
ii  libgcc1                1:4.7.2-5
ii  libgnutls26            2.12.20-6
ii  libgssapi-krb5-2       1.10.1+dfsg-5
ii  libkrb5-3              1.10.1+dfsg-5
ii  libldap-2.4-2          2.4.31-1+nmu2
ii  libpam0g               1.1.3-7.1
ii  libpaper1              1.1.24+nmu2
ii  libslp1                1.2.1-9
ii  libstdc++6             4.7.2-5
ii  libusb-1.0-0           2:1.0.11-1
ii  lsb-base               4.1+Debian8
ii  poppler-utils          0.18.4-6
ii  procps                 1:3.3.3-3
ii  ssl-cert               1.0.32

Versions of packages cups recommends:
ii  avahi-daemon               0.6.31-2
ii  colord                     0.1.21-1
ii  foomatic-filters           4.0.17-1
ii  ghostscript-cups           9.05~dfsg-6.3
ii  printer-driver-gutenprint  5.2.9-1

Versions of packages cups suggests:
ii  cups-bsd               1.5.3-5
pn  cups-pdf               <none>
ii  foomatic-db            20120523-1
ii  hplip                  3.12.6-3.1
ii  printer-driver-hpcups  3.12.6-3.1
ii  smbclient              2:3.6.6-6
ii  udev                   175-7.1

-- debconf information:
  cupsys/raw-print: true
  cupsys/backend: ipp, ipp14, lpd, socket, usb, snmp, dnssd


Reply to: