[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#610928: Backward compatibility script needed for HP PPD upgrade

The Debian packages of HPLIP (hplip, hplip-cups, hpijs, and hpijs-ppds) should generally update the PPDs of the existing print queues to the current packages version in the post-install scripts. Can you attach the PPD(s) which did not get updated automatically to this bug report? Thanks.


On 01/24/2011 02:47 AM, Kevin Shanahan wrote:
Package: hpijs-ppds
Version: 3.10.6-1.1

On upgrade from Lenny to Squeeze a number of our printer queues
stopped working with the following error logged:

D [24/Jan/2011:08:54:10 +1030] [Job 449496] prnt/hpcups/HPCupsFilter.cpp 361: DEBUG: Bad PPD - hpPrinterLanguage not found
D [24/Jan/2011:08:54:10 +1030] [Job 449496] prnt/backend/hp.c 839: ERROR: null print job total=0

The upgrade also reset the default paper size to weird values on a
bunch of other HP printers. I found this info on the redhat bugzilla:


I grabbed a copy of hpijs-3.10.9-1.fc12.x86_64.rpm, extracted the
hpcups-update-ppds script and ran it. This fixed all the issues caused
by the upgrade. Debian should have something like this for Squeeze.


Reply to: