[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#583229: marked as done (cups-bsd: lpr ignores the Duplex=None setting)

Your message dated Tue, 6 Jul 2010 15:34:22 +0400 (MSD)
with message-id <46662.>
and subject line 
has caused the Debian Bug report #583229,
regarding cups-bsd: lpr ignores the Duplex=None setting
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

583229: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583229
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cups-bsd
Version: 1.4.3-1
Severity: normal

I use cups and cups-bsd with a network hp laserjet p2055dn printer.
Using the web interface http://localhost:631 I set the default option
for Duplex to be "Flip on Long Edge (Standard)".
Printing from gui programs (e.g., iceweasel) works OK, both duplex
and non-duplex.  But lpr print duplex always, namely the command
$ lpr -o Duplex=None test.ps
prints duplex.

If I set Duplex Off default (via http://localhost:631) then lpr
works correctly, that is
$ lpr -o Duplex=DuplexNoTumble test.ps
prints duplex.

This bug doesn't exist in the stable version 1.3.8-1+lenny8.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (600, 'testing'), (400, 'unstable'), (400, 'stable'), (300, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.33-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cups-bsd depends on:
ii  cups-client                   1.4.3-1    Common UNIX Printing System(tm) - 
ii  cups-common                   1.4.3-1    Common UNIX Printing System(tm) - 
ii  debconf [debconf-2.0]         1.5.32     Debian configuration management sy
ii  libc6                         2.10.2-9   Embedded GNU C Library: Shared lib
ii  libcups2                      1.4.3-1    Common UNIX Printing System(tm) - 
ii  update-inetd                  4.36       inetd configuration file updater

cups-bsd recommends no packages.

Versions of packages cups-bsd suggests:
ii  cups                          1.4.3-1    Common UNIX Printing System(tm) - 

-- debconf information:
  cups-bsd/setuplpd: false

--- End Message ---
--- Begin Message ---
Package: cups-bsd
Version: 1.4.4-1

With version 1.4.4-1 I cannot reproduce this bug any longer.

--- End Message ---

Reply to: