[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Call for testers: Gutenprint 5.2.1-2 in experimental

Hi folks,

The new release of Gutenprint, 5.2.1, has been packaged and uploaded to
unstable.  However, I currently lack an inkjet printer in order to test
it.  If you have five minutes to install and test printing, I would be
grateful for any feedback.  Once Lenny has been released and any major
bugs have been ironed out, this will be uploaded to experimental.

Simply printing a test page from CUPS after installing the library and
cups-driver-gutenprint package would be sufficient, though any more
detailed testing would also be appreciated, e.g. of the gimp-gutenprint
plugin or the ijs server driver ijsgutenprint with foomatic.

If you used the old "canon" or "epson" CUPS backends to drive a
parallel-, USB- or network socket-connected printer, these two backends
were removed by upstream (obsolete).  I added some logic to the
cups-driver-gutenprint postinst to migrate to one of the "parallel",
"usb",or "socket" backends where possible.  However, the process isn't
perfect because the USB device naming for the USB backend no longer
allows plain device nodes, so these devices will require the queue to
be manually modified, e.g. using the CUPS web interface or lpadmin.

CUPS now supports fully internationalised PPD files, which will be
created correctly only if the gutenprint-locales package is installed.
Not all applications yet display the translations, however.  You may
just get English if the application does not look at the translations.

Packages available here:

Suggested packages to install (in order):

The package sources are in git:


  .''`.  Roger Leigh
 : :' :  Debian GNU/Linux             http://people.debian.org/~rleigh/
 `. `'   Printing on GNU/Linux?       http://gutenprint.sourceforge.net/
   `-    GPG Public Key: 0x25BFB848   Please GPG sign your mail.

Attachment: signature.asc
Description: Digital signature

Reply to: