[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#474109: marked as done (cupsys: cupsd fails to load the *.convs files in /usr/share/cups/mime)

Your message dated Mon, 09 Jun 2008 15:16:20 +0000
with message-id <E1K5j6a-0005GY-Uv@ries.debian.org>
and subject line Bug#474109: fixed in cups 1.3.7-6
has caused the Debian Bug report #474109,
regarding cupsys: cupsd fails to load the *.convs files in /usr/share/cups/mime
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

474109: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=474109
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cupsys
Version: 1.3.6-3
Severity: normal

It looks like cupsd will tend to fail to load the *.convs files in
/usr/share/cups/mime, while the *.types in the same directory are
loaded correctly. Because cupsys ships the two files oopstops.convs
and oopstops.types in that directory, this results in the following
error message when trying to print a PostScript file generated by
OpenOffice.org 2.0 (the version in etch). (For what it's worth, I've
also attached a copy of this file.)

$ lpr test-oo2.0.ps 
lpr: Unsupported format 'application/openofficeps'!

The error does not occur when printing PS files generated by
OpenOffice 2.4, because they do not seem to match with the MIME
type description in oopstops.types. (The PS files generated by
OpenOffice 2.4 includes the comment "%%Creator: (OpenOffice.org 2.4)",
while those generated by OpenOffice 2.0 has the comment
"%%Creator: OpenOffice.org 2.0".)

Anyway, I tried to recompile CUPS with CFLAGS=-DDEBUG. (First this
failed, but two trivial workarounds made it work.) The following lines
are from near the beginning of the long sequence of debug messages
which was printed after I started the recompiled cupsd:

application/openofficeps string(0,%!) + contains(0,1024,"%%Creator: OpenOffice.org 2.")
application/openofficeps:  string(0,%!) + contains(0,1024,"%%Creator: OpenOffice.org 2.")
making new OR group 0x80b1f20 for parenthesis...
adding 0x80b1f88: string, op = 6, logic = 2, invert = 0
setting group 0x80b1f20 op to AND...
adding 0x80b1ff0: contains, op = 11, logic = 1, invert = 0
application/openofficeps application/postscript 33 oopstops
    Destination type application/postscript not found!

As the debug message indicates, the problem seems to be that cupsd
refuses to load the conversion rule for application/openofficeps,
because it has not loaded any MIME type description for
application/postscript yet. The reason for this appears to be the
patch search_mime_files_in_usr_share.dpatch, which seem to cause the
*.types files in /etc/cups, including mime.types with the MIME type
description for application/postscript, to be loaded after the *.convs
files in /usr/share/cups/mime.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages cupsys depends on:
ii  adduser               3.107              add and remove users and groups
ii  cupsys-common         1.3.6-3            Common UNIX Printing System(tm) - 
ii  debconf [debconf-2.0] 1.5.20             Debian configuration management sy
ii  ghostscript           8.62.dfsg.1-2      The GPL Ghostscript PostScript/PDF
ii  ghostscript-x [gs-esp 8.62.dfsg.1-2      The GPL Ghostscript PostScript/PDF
ii  libavahi-compat-libdn 0.6.22-2           Avahi Apple Bonjour compatibility 
ii  libc6                 2.7-10             GNU C Library: Shared libraries
ii  libcupsimage2         1.3.6-3            Common UNIX Printing System(tm) - 
ii  libcupsys2            1.3.6-3            Common UNIX Printing System(tm) - 
ii  libdbus-1-3           1.1.20-1           simple interprocess messaging syst
ii  libgnutls26           2.2.2-1            the GNU TLS library - runtime libr
ii  libkrb53              1.6.dfsg.3~beta1-4 MIT Kerberos runtime libraries
ii  libldap-2.4-2         2.4.7-6.1          OpenLDAP libraries
ii  libpam0g             Pluggable Authentication Modules l
ii  libpaper1             1.1.23             library for handling paper charact
ii  libslp1               1.2.1-7.2          OpenSLP libraries
ii  lsb-base              3.2-6              Linux Standard Base 3.2 init scrip
ii  perl-modules          5.8.8-12           Core Perl modules
ii  procps                1:3.2.7-6          /proc file system utilities
ii  ssl-cert              1.0.17             simple debconf wrapper for OpenSSL
ii  xpdf-utils [poppler-u 3.02-1.3           Portable Document Format (PDF) sui

Versions of packages cupsys recommends:
ii  avahi-utils             0.6.22-2         Avahi browsing, publishing and dis
ii  cupsys-client           1.3.6-3          Common UNIX Printing System(tm) - 
ii  foomatic-filters        3.0.2-20080211-3 OpenPrinting printer support - fil
ii  smbclient               3.0.28a-1        a LanManager-like simple client fo

-- debconf information:
* cupsys/raw-print: true
  cupsys/ports: 631
* cupsys/backend: ipp, lpd, parallel, scsi, serial, socket, usb, snmp, dnssd
  cupsys/browse: true

Attachment: test-oo2.0.ps
Description: PostScript document

--- End Message ---
--- Begin Message ---
Source: cups
Source-Version: 1.3.7-6

We believe that the bug you reported is fixed in the latest version of
cups, which is due to be installed in the Debian FTP archive:

  to pool/main/c/cups/cups-bsd_1.3.7-6_amd64.deb
  to pool/main/c/cups/cups-client_1.3.7-6_amd64.deb
  to pool/main/c/cups/cups-common_1.3.7-6_all.deb
  to pool/main/c/cups/cups-dbg_1.3.7-6_amd64.deb
  to pool/main/c/cups/cups_1.3.7-6.diff.gz
  to pool/main/c/cups/cups_1.3.7-6.dsc
  to pool/main/c/cups/cups_1.3.7-6_amd64.deb
  to pool/main/c/cups/cups_1.3.7.orig.tar.gz
  to pool/main/c/cups/cupsys-bsd_1.3.7-6_all.deb
  to pool/main/c/cups/cupsys-client_1.3.7-6_all.deb
  to pool/main/c/cups/cupsys-dbg_1.3.7-6_all.deb
  to pool/main/c/cups/cupsys_1.3.7-6_all.deb
  to pool/main/c/cups/libcups2-dev_1.3.7-6_amd64.deb
  to pool/main/c/cups/libcups2_1.3.7-6_amd64.deb
  to pool/main/c/cups/libcupsimage2-dev_1.3.7-6_amd64.deb
  to pool/main/c/cups/libcupsimage2_1.3.7-6_amd64.deb
  to pool/main/c/cups/libcupsys2-dev_1.3.7-6_all.deb
  to pool/main/c/cups/libcupsys2_1.3.7-6_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 474109@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Martin Pitt <mpitt@debian.org> (supplier of updated cups package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 23 May 2008 00:32:17 +0200
Source: cups
Binary: libcups2 libcupsimage2 cups cups-client libcups2-dev libcupsimage2-dev cups-bsd cups-common cups-dbg cupsys cupsys-client cupsys-bsd cupsys-dbg libcupsys2 libcupsys2-dev
Architecture: source all amd64
Version: 1.3.7-6
Distribution: unstable
Urgency: low
Maintainer: Debian CUPS Maintainers <pkg-cups-devel@lists.alioth.debian.org>
Changed-By: Martin Pitt <mpitt@debian.org>
 cups       - Common UNIX Printing System(tm) - server
 cups-bsd   - Common UNIX Printing System(tm) - BSD commands
 cups-client - Common UNIX Printing System(tm) - client programs (SysV)
 cups-common - Common UNIX Printing System(tm) - common files
 cups-dbg   - Common UNIX Printing System(tm) - debugging symbols
 cupsys     - Common UNIX Printing System (transitional package)
 cupsys-bsd - Common UNIX Printing System (transitional package)
 cupsys-client - Common UNIX Printing System (transitional package)
 cupsys-dbg - Common UNIX Printing System (transitional package)
 libcups2   - Common UNIX Printing System(tm) - libs
 libcups2-dev - Common UNIX Printing System(tm) - development files
 libcupsimage2 - Common UNIX Printing System(tm) - image libs
 libcupsimage2-dev - Common UNIX Printing System(tm) - image development files
 libcupsys2 - Common UNIX Printing System (transitional package)
 libcupsys2-dev - Common UNIX Printing System (transitional package)
Closes: 474109 482296
 cups (1.3.7-6) unstable; urgency=low
   * Rename the package to cups. This is the proper upstream name. Upstream has
     made it clear that the usual distro patches are not a trademark violation.
     This unbreaks all the documentation out there, which refers to "cups", not
     "cupsys" (including names of the init script), as well as unbreaks
     dependencies of openprinting.org's LSB printer driver packages.
     (Closes: #482296, LP: #233790)
   * debian/cups.{config,postinst}: Remove some old cruft.
   * debian/cups.preinst: Move conffiles to new names on upgrades, in a dpkg
     conffile question avoiding manner.
   * debian/cupsys.install: Install oopstops.{convs,types} in /etc/cups, they
     do not work in /usr/share/cups/mime (loaded too early). (Closes: #474109)
 00e6f7f59ca67702134a2239b9f3db67d93d4a93 1768 cups_1.3.7-6.dsc
 8c16344a26d45eecbc06c9986aaca17308a495d1 4700333 cups_1.3.7.orig.tar.gz
 6ad37f69572b47686e8eae48e3ff9bd9d2e9d319 110844 cups_1.3.7-6.diff.gz
 c39068e432a2f8020a7cc7ad9d673791c8924e7d 1129528 cups-common_1.3.7-6_all.deb
 3aa0c9e280bcf97c730b417cc91a9d7418a652c3 48038 cupsys_1.3.7-6_all.deb
 2dbeafcc8cf8832bb4227b9c085103961b05fe5f 48054 cupsys-client_1.3.7-6_all.deb
 0061c08278c287aabcc224740f0c932bbe58f1bc 48050 cupsys-bsd_1.3.7-6_all.deb
 3a43201ad7ff1ea28299a105eb1a22e965317a9a 48050 cupsys-dbg_1.3.7-6_all.deb
 1560a366960ca5bf7acdaac00cfa8df2337a7d94 48050 libcupsys2_1.3.7-6_all.deb
 a522492fadb7cdf284e6a1b5d7b2a4bafbdb55ec 48060 libcupsys2-dev_1.3.7-6_all.deb
 836d822b80b3c729cdeb8973954ba8daf0258cd2 160990 libcups2_1.3.7-6_amd64.deb
 5d08caeec11e1b6370c4eb4090fd2f084b00f46b 94786 libcupsimage2_1.3.7-6_amd64.deb
 20710c8a4acf9f55be2a9bbd3ba1de03babc60fb 1944888 cups_1.3.7-6_amd64.deb
 d27948c3b1526163fc8c0b7900050d2c33140bfd 89774 cups-client_1.3.7-6_amd64.deb
 b8347101b80da51c06c8a5fa87cf888bf4a142fc 391810 libcups2-dev_1.3.7-6_amd64.deb
 923570f9f3496250a91ee36463beaa99c306a527 60586 libcupsimage2-dev_1.3.7-6_amd64.deb
 4bd68a887c5ba66ab586067cb019e13f2df4d53e 28896 cups-bsd_1.3.7-6_amd64.deb
 8e131c1f168e2f0832e6c6b5a207093a4d107663 1143324 cups-dbg_1.3.7-6_amd64.deb
 7531166eb76b85d783b3ea93a3078b4d9ab5f7a32da359d83cb5e00cd440c849 1768 cups_1.3.7-6.dsc
 7160cb287b515947abaeb048380ee116c14312d51961d5e7b15043a7d7e304ba 4700333 cups_1.3.7.orig.tar.gz
 af56cbde33edeedfdacd3b9c7f7e01a00cfbdf5cce749bdde97bd5e2b6f211d8 110844 cups_1.3.7-6.diff.gz
 7c6d63b65014022a32578f5b11ce9a5ccf667d64f3a10b19395888c53e60925c 1129528 cups-common_1.3.7-6_all.deb
 d322974d75935e741b007ba4ca82b54f6eba284e340374d96b6b892c321f53e6 48038 cupsys_1.3.7-6_all.deb
 17de3751d59e45d9cb19df5c13e4234d36dfd832b26e3ac031dfe8c8bd4cc957 48054 cupsys-client_1.3.7-6_all.deb
 9456078b06f67e25c2287640a833021cd99dc1652f4a92c7570fc4b2c671ac59 48050 cupsys-bsd_1.3.7-6_all.deb
 f2a3e20b6805b4e113b18a8c2b6aa5b45f61dfc39601365ac9d20120609eb4d4 48050 cupsys-dbg_1.3.7-6_all.deb
 37d65a31be5f4715f84e4483b3c95f52efe7aeb01ceba56775aa5a12ff3226ed 48050 libcupsys2_1.3.7-6_all.deb
 c48fb6c1ce1ac84785494587f2d03da2613123fc141fcfc76502fea6551af557 48060 libcupsys2-dev_1.3.7-6_all.deb
 2668cb7bf729f8e9d24be58a3818e11feba3136dd1151b1ecb5f990a7d0e4529 160990 libcups2_1.3.7-6_amd64.deb
 f98470e32c67bc6d0884c35666209adf7a8e2c290a042fca41fde72927aa22a1 94786 libcupsimage2_1.3.7-6_amd64.deb
 9a028f1fb8d535c1268aef3ce31e3bfaab8802116b48e85deacf92c1001d185a 1944888 cups_1.3.7-6_amd64.deb
 dc82ebea5c116ed1b60b42b41f7205da487fb86aee2265e5e81ac2c834bb4c17 89774 cups-client_1.3.7-6_amd64.deb
 ce9256363550f328f3e06f9222f2c671d62e7293570201e486dcf02342960c88 391810 libcups2-dev_1.3.7-6_amd64.deb
 a264b26a69126b6164a67c8b28d4ad36fe87dd6c8cd695c02e76e58a4e56a7ba 60586 libcupsimage2-dev_1.3.7-6_amd64.deb
 c28b5c376285958da8a2d80147a7b8aa65dce9271f26fd2fa69ec423fb5eefbb 28896 cups-bsd_1.3.7-6_amd64.deb
 a4507e73ba0c0c57b9b89ec9f5ea16c8a3d047522f0ec0fae6c9fca4db4181a5 1143324 cups-dbg_1.3.7-6_amd64.deb
 c584339edfc5238d8b4ce381ffd8d8e1 1768 net optional cups_1.3.7-6.dsc
 383e556d9841475847da6076c88da467 4700333 net optional cups_1.3.7.orig.tar.gz
 db11ee81aad9232902c5066a5a782e25 110844 net optional cups_1.3.7-6.diff.gz
 ac7ce73d7ea293011806e1aff816fe4e 1129528 net optional cups-common_1.3.7-6_all.deb
 e56f47729591e08841907f20a568d6d6 48038 oldlibs extra cupsys_1.3.7-6_all.deb
 510d8bc4c84e7a33e54d1ed0382aa232 48054 oldlibs extra cupsys-client_1.3.7-6_all.deb
 50c5e71045240c540ebcee575f3080a6 48050 oldlibs extra cupsys-bsd_1.3.7-6_all.deb
 a48cd65d897f256ceaaea612ebf46c6a 48050 oldlibs extra cupsys-dbg_1.3.7-6_all.deb
 8488872c5657785622b8594094a38f68 48050 oldlibs extra libcupsys2_1.3.7-6_all.deb
 a32dca3ef730f1511aba38e08df829dd 48060 oldlibs extra libcupsys2-dev_1.3.7-6_all.deb
 b2d3b47fe988abf06535fd72ec5679c9 160990 libs optional libcups2_1.3.7-6_amd64.deb
 f6fd39d39a8592e55c1a4d5ff016b4b3 94786 libs optional libcupsimage2_1.3.7-6_amd64.deb
 f05933b791916850042f92ef996bbca5 1944888 net optional cups_1.3.7-6_amd64.deb
 2da461981b8a544b12b9689bd220bb75 89774 net optional cups-client_1.3.7-6_amd64.deb
 15323ac43de150ce836132b5f2ac480d 391810 libdevel optional libcups2-dev_1.3.7-6_amd64.deb
 be2609475ac53e2806a29de35b7e0a58 60586 libdevel optional libcupsimage2-dev_1.3.7-6_amd64.deb
 2ac394547efeaa53143bd2414fa41c7f 28896 net extra cups-bsd_1.3.7-6_amd64.deb
 bcaceaebe9481616298f794716feb8e4 1143324 libdevel extra cups-dbg_1.3.7-6_amd64.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: