[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#417874: marked as done (Translation update)

Your message dated Mon, 14 May 2007 08:47:04 +0000
with message-id <E1HnWCu-0004Gy-5L@ries.debian.org>
and subject line Bug#417874: fixed in cupsys 1.2.11-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: cupsys
Version: 1.2.7-4
Severity: wishlist

Attachment: ru.po.bz2
Description: BZip2 compressed data

--- End Message ---
--- Begin Message ---
Source: cupsys
Source-Version: 1.2.11-1

We believe that the bug you reported is fixed in the latest version of
cupsys, which is due to be installed in the Debian FTP archive:

  to pool/main/c/cupsys/cupsys-bsd_1.2.11-1_i386.deb
  to pool/main/c/cupsys/cupsys-client_1.2.11-1_i386.deb
  to pool/main/c/cupsys/cupsys-common_1.2.11-1_all.deb
  to pool/main/c/cupsys/cupsys-dbg_1.2.11-1_i386.deb
  to pool/main/c/cupsys/cupsys_1.2.11-1.diff.gz
  to pool/main/c/cupsys/cupsys_1.2.11-1.dsc
  to pool/main/c/cupsys/cupsys_1.2.11-1_i386.deb
  to pool/main/c/cupsys/cupsys_1.2.11.orig.tar.gz
  to pool/main/c/cupsys/libcupsimage2-dev_1.2.11-1_i386.deb
  to pool/main/c/cupsys/libcupsimage2_1.2.11-1_i386.deb
  to pool/main/c/cupsys/libcupsys2-dev_1.2.11-1_i386.deb
  to pool/main/c/cupsys/libcupsys2_1.2.11-1_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 417874@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Martin Pitt <mpitt@debian.org> (supplier of updated cupsys package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 14 May 2007 09:23:16 +0200
Source: cupsys
Binary: libcupsys2-dev cupsys libcupsys2 libcupsimage2 cupsys-common cupsys-client cupsys-dbg cupsys-bsd libcupsimage2-dev
Architecture: source i386 all
Version: 1.2.11-1
Distribution: unstable
Urgency: low
Maintainer: Debian CUPS Maintainers <pkg-cups-devel@lists.alioth.debian.org>
Changed-By: Martin Pitt <mpitt@debian.org>
 cupsys     - Common UNIX Printing System(tm) - server
 cupsys-bsd - Common UNIX Printing System(tm) - BSD commands
 cupsys-client - Common UNIX Printing System(tm) - client programs (SysV)
 cupsys-common - Common UNIX Printing System(tm) - common files
 cupsys-dbg - Common UNIX Printing System(tm) - debugging symbols
 libcupsimage2 - Common UNIX Printing System(tm) - image libs
 libcupsimage2-dev - Common UNIX Printing System(tm) - image development files
 libcupsys2 - Common UNIX Printing System(tm) - libs
 libcupsys2-dev - Common UNIX Printing System(tm) - development files
Closes: 416350 416356 416357 416367 416385 416401 416407 416939 416994 417249 417874 418030 418135 418299 421899
 cupsys (1.2.11-1) unstable; urgency=low
   [ Kenshi Muto ]
   * Applied templates improvement patch contributed by
     debian-l10n-english team. (closes: #416350)
   * Debconf translation
     - Japanese
     - Galician (closes: #416357)
     - Swedish (closes: #416356)
     - Catalan (closes: #416367)
     - Basque (closes: #416385)
     - Norwegian (closes: #416401)
     - Italian (closes: #416407)
   * New upstream version 1.2.11:
     - 56_dirsvc patch is merged.
   [ Christian Perrier ]
   * Debconf translation
     - Czech (closes: #416939)
     - German (closes: #416994)
     - Brazilian Portuguese (closes: #417249)
     - French
     - Malayalam. (closes: #418030)
     - Russian. (closes: #417874)
     - Dutch. (closes: #418135)
     - Portuguese (closes: #418299)
   [ Martin Pitt ]
   * New upstream bugfix release (closes: #421899).
   Synchronize patches with Ubuntu and new upstream version 1.2.10:
   * Drop patches which are fixed upstream:
     00_00str2111.dpatch, 00_01str2137.dpatch, 00_02str2144.dpatch,
     00_03str2106.dpatch, 00_04str2117.dpatch, 00_05str2133.dpatch,
     00_06str2121.dpatch, 00_07str2123.dpatch, 00_08str2135.dpatch,
     00_09str2198.dpatch, 03_clean.dpatch, 65_detect_http_shutdown.dpatch
   * Remove a few obsolete patches:
     08_cupsd.conf.conf.d.dpatch, 26_modprobe.dpatch, 48_stdlib.dpatch,
     61_job_c_strangeloop.dpatch, 08_cupsd.conf.conf.d.dpatch,
   * Add debian/patches/14_dont_force_ssl.dpatch: Do not require SSL for /admin
     pages, since gnome-cups-manager (and most probably other GUI frontends)
     does not support this.
   * Add debian/patches/58_cupsd.conf-AllowLocal.dpatch: Allow access to local
     ethernet by default. This just affects the ACL, for actually enabling
     access cupsd needs to be switched to not only listen on localhost. With
     that, this setting does not need to be configured in two different places.
   * Add debian/patches/70_reactivate_recommended_driver.dpatch: Upstream CUPS
     filters the "(recommended)" marking from the NickNames of the PPD files
     when listing PPDs. These are an important orientation for the user and
     they are also made use of by some printer setup tools. We need them at
     least until a better solution for recommending drivers gets available.
   * Add debian/patches/98_search_mime_files_in_usr_share.dpatch: Let CUPS also
     search for *.types and *.convs files in /usr/share/cups/mime. This way
     packages can provide *.types and *.convs files which do not get considered
     as conffiles. (See https://launchpad.net/36532 for details).
   * debian/patches/*.dpatch: Forwarded a lot of patches to upstream bug
     tracker, add STR URLs to dpatch DP: headers.
   Synchronize packaging with Ubuntu:
   * debian/control: Drop transitional libcupsys2-gnutls10 package, it was only
     required for Sarge->Etch upgrades.
   * debian/control: Change netbase dependency to update-inetd, since that
     lives in its own package now.
   * debian/local/enable_sharing: Also match on IP adresses in
     addition to 'localhost'.
   * debian/rules: Most of the clean:: rule is obsolete, only two files are
     left behind now. These two have been reported upstream in
   * debian/cupsys.templates: Activate SCSI, serial, and SNMP backends by
     default. With these backends activated, many printers can be easily set up
     with the printer setup tools.  Especially network printers get
     auto-detected and the correct URI gets assigned to them (doing this
     manually is a non-trivial task for most users).
   * debian/cupsys.dirs: Add /usr/share/ppd/custom/, a place where lpadmins can
     store additional PPDs (this functionality is e. g. provided in
     gnome-cups-manager's "Custom driver..." file dialog).
   * debian/cupsys.init.d: Give proper permissions to /usr/share/ppd/custom/:
     root:lpadmin 3775. Drop the obsolete chmod/chowning of
   * Run the backend as non-root system user to confine the impact of security
     - Add debian/patches/10_external_pam_helper.dpatch:
       + Add a helper program 'cups-check-pam-auth' which performs PAM
         authentication and returns the status as exit code.
       + scheduler/auth.c, cupsdAuthorize(): Attempt to use
         cups-check-pam-auth before trying native PAM.
       + With this we do not need to put the cupsys user into the shadow group.
     - debian/cupsys.files: Install PAM helper.
     - debian/cupsys.postinst: Set permissions of PAM helper to cupsys:shadow
       2754, alter permissions of some configuration files and directories to
       work with non-root cupsd.
     - debian/cupsys.postinst: Fix /var/cache/cups/ permissions for upgrades
       which might have written cache files as root.
     - debian/cupsys.logrotate: Save log files as cupsys:lpadmin.
     - debian/cupsys.init.d: Disable 'reload'; change force-reload to restart,
       since cupsd cannot reload as non-root.
     - debian/cupsys.init.d: Set up proper permissions of log files.
     - debian/rules: Enable --enable-privilege-dropping configure option.
     - debian/rules: Install lpd backend suid root, so that it can bind to
       ports < 1024 (really silly, but required for RFC compliance).
     - debian/cupsys-client.postinst, debian/cupsys.postinst: Set up cupsys
       system user.
   * debian/NEWS: Describe derooting.
 17bb771564532e9ec3fe38658c70a12e 1088 net optional cupsys_1.2.11-1.dsc
 44e29cb2040f30791d6032d26323a9b5 4405184 net optional cupsys_1.2.11.orig.tar.gz
 2f783e0c77d21afb13e8d75ecd04a540 100130 net optional cupsys_1.2.11-1.diff.gz
 6b1d8ae2f97a61da35622a6dd5ce87d5 935220 net optional cupsys-common_1.2.11-1_all.deb
 1e64f1fe867827cf3914af1e7c59d877 164648 libs optional libcupsys2_1.2.11-1_i386.deb
 70a67fbfa6962baf22b20a420d0e2f19 91824 libs optional libcupsimage2_1.2.11-1_i386.deb
 b15b175c4ffd011da0b4fae904b946e7 1668420 net optional cupsys_1.2.11-1_i386.deb
 7ed56145ea6a9181404558c6bc74133b 80450 net optional cupsys-client_1.2.11-1_i386.deb
 86cb8303e8f88ef53f7645bdfeca977d 137610 libdevel optional libcupsys2-dev_1.2.11-1_i386.deb
 a8c07e83d34d94898ffe41ab255bdce4 54906 libdevel optional libcupsimage2-dev_1.2.11-1_i386.deb
 0ead69f06b4ea0f30027773a653b7c76 35650 net extra cupsys-bsd_1.2.11-1_i386.deb
 8395a7864e503c0e596fe7965f16cf8d 996182 libdevel extra cupsys-dbg_1.2.11-1_i386.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: